Opened 3 years ago

Closed 3 years ago

#21203 closed defect (fixed)

sandbox-0.0.2-linux32 does not seem to work on Debian Jessie

Reported by: Digitalcourage Owned by: yawning
Priority: High Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I tried this on two older laptops. One is running, Debian Jessie 32 bit, the other LMDE2 32 bit which is based on Debian Jessie. In each case I use bubblewrap from jessie-backports. The same thing happens after I download, verify and unzip sandbox-0.0.2-linux32.zip:

$ ./sandboxed-tor-browser
2017/01/12 01:26:35 install: Starting.
2017/01/12 01:26:35 install: Checking available downloads.
2017/01/12 01:26:37 install: Version: 6.0.8 Downloads: &{https://dist.torproject.org/torbrowser/6.0.8/tor-browser-linux32-6.0.8_en-US.tar.xz.asc https://dist.torproject.org/torbrowser/6.0.8/tor-browser-linux32-6.0.8_en-US.tar.xz}
2017/01/12 01:26:37 install: Downloading https://dist.torproject.org/torbrowser/6.0.8/tor-browser-linux32-6.0.8_en-US.tar.xz
2017/01/12 01:27:55 install: Downloading https://dist.torproject.org/torbrowser/6.0.8/tor-browser-linux32-6.0.8_en-US.tar.xz.asc
2017/01/12 01:27:56 install: Validating Tor Browser PGP Signature.
2017/01/12 01:28:07 install: Installing Tor Browser.
2017/01/12 01:29:36 install: Complete.
2017/01/12 01:29:47 launch: Starting.
2017/01/12 01:29:47 launch: Connecting to the Tor network.
2017/01/12 01:29:48 tor: setsid
2017/01/12 01:29:48 tor: : Function not implemented
2017/01/12 01:29:58 launch: Failing with error: tor: timeout waiting for the control port

The final error message appears after the popup window labeled “Waiting on Tor bootstrap” is shown for approx. 7 seconds.

It does not matter whether I choose the stable or alpha build. I can install them, but I cannot start them. In each case, I kept the default l10n (en-US) and other settings on default, too.

Retrying does not help:

$ ./sandboxed-tor-browser
2017/01/12 01:37:20 launch: Starting.
2017/01/12 01:37:20 launch: Connecting to the Tor network.
2017/01/12 01:37:21 tor: setsid
2017/01/12 01:37:21 tor: : Function not implemented
2017/01/12 01:37:31 launch: Failing with error: tor: timeout waiting for the control port

I am unable to tell if the failure to start TorBrowser is caused by the “Function not implemented” problem or by a short timeout value when waiting for Tor to come up or something else.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by yawning

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.