Opened 2 years ago

Closed 23 months ago

#21283 closed defect (fixed)

Remove broken fallback directory mirrors

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: fallback, 028-backport, 029-backport, TorCoreTeam201703
Cc: Actual Points:
Parent ID: #21564 Points: 1
Reviewer: Sponsor:

Description

Some time around 0.3.0.?-rc, we should remove all non-functional fallback directories from the December 2016 list (or rebuild the entire list).

I'll create a draft branch here, but the script should be re-run just before the release (and ideally, operators should be contacted and given an opportunity to fix any errors).

Child Tickets

Attachments (1)

fallback_dirs_2017-02-14-2310_60c4a1ed35.log (495.0 KB) - added by teor 2 years ago.
Log for fallback directory check existing

Download all attachments as: .zip

Change History (20)

comment:1 Changed 2 years ago by teor

Status: newneeds_revision

See my branch bad-fallbacks-201701-028, which needs:

  • operators to be contacted,
  • the script to be re-run just before 0.3.0.?-rc

comment:2 Changed 2 years ago by teor

The operator of fallback directory mirror FA3415659444AE006E7E9E5375E82F29700CFDFD has emailed me to ask for it to be removed.

The fallback check yesterday already detected an issue and removed it from the list in my branch bad-fallbacks-201701-028.

comment:3 Changed 2 years ago by dgoulet

Status: needs_revisionneeds_review

comment:4 Changed 2 years ago by teor

Status: needs_reviewneeds_revision

No, this needs revision: operators need to be contacted, and then the script should be run again.

comment:5 Changed 2 years ago by teor

The whitelist and script changes are in #21121.
The branch is now bad-fallbacks-201702-028, but I'll wait a week or two after contacting operators and re-run the script.

Changed 2 years ago by teor

Log for fallback directory check existing

comment:6 Changed 2 years ago by teor

(I won't email tor-team, 31 emails is a few too many.)

comment:7 Changed 2 years ago by teor

I emailed 12 operators about 15 relays.
(The remaining 16 were long-term downtime or low averages, which operators can't fix.)

11 relays were on very old or non-recommended versions.
2 relays had added IPv6 addresses.
1 relay required a manual IPv6 address update due to #21460.

If everyone upgrades, we should be back to around ~160 fallbacks in a week or two when the list is regenerated.

comment:8 in reply to:  7 Changed 2 years ago by teor

Replying to teor:

2 relays had added IPv6 addresses.
1 relay required a manual IPv6 address update due to #21460.

All these 3 relays will require their IPv6 addresses to be added manually.
I'll do that when I get confirmation from their operators that the IPv6 addresses are permanent.

comment:9 Changed 2 years ago by teor

8C00FA7369A7A308F6A137600F0FA07990D9D451 confirmed [2001:bc8:225f:142:6c69:7461:7669:73]:9001

comment:10 Changed 2 years ago by teor

9BF04559224F0F1C3C953D641F1744AF0192543A confirmed [2a01:4f8:190:34f0::2]:4223

I need to add both these addresses to the whitelist, and manually add them to the generated fallback list.

comment:11 Changed 2 years ago by nickm

Keywords: TorCoreTeam201703 added

comment:12 Changed 2 years ago by teor

I also need to remove DF3AED4322B1824BF5539AE54B2D1B38E080FF05 from the list, as the operator has opted-out.

comment:13 Changed 2 years ago by teor

Milestone: Tor: 0.3.0.x-finalTor: 0.3.1.x-final

comment:14 Changed 23 months ago by teor

I also need to remove F80FDE27EFCB3F6A7B4E2CC517133DBFFA78BA2D and 4FEE77AFFD157BBCF2D896AE417FBF647860466C as they have been shut down.

comment:15 Changed 23 months ago by teor

Milestone: Tor: 0.3.1.x-finalTor: 0.3.2.x-final

This won't make the 0.3.1 freeze, and isn't needed yet, because 90% of the fallback directories are still running, which gives us 99.9% client success when trying 3 fallbacks.

https://consensus-health.torproject.org/graphs.html#fallbackdirgraphs

comment:16 Changed 23 months ago by teor

The operator of 5.35.251.247 will replace it with 91.250.84.156, possibly with new keys.
We can handle this using the normal rebuild process.

comment:17 Changed 23 months ago by teor

We also want to remove kitten2=2EBD117806EE43C3CC885A8F1E4DC60F207E7D3E due to #22268.

comment:18 Changed 23 months ago by teor

Parent ID: #21564

comment:19 Changed 23 months ago by teor

Resolution: fixed
Status: needs_revisionclosed

The whitelist and blacklist changes here are in my branch fallback-inputs, and will be dealt with in #21121.

I rebuilt the list rather than dropping old fallbacks. I'll handle that in #21564.

Note: See TracTickets for help on using tickets.