Opened 5 weeks ago

Closed 4 weeks ago

#21300 closed defect (fixed)

Recent changes broke GETCONF *Port

Reported by: atagar Owned by: nickm
Priority: Very High Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version:
Severity: Major Keywords: regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi Nick, shot ya an email earlier about this. Tor changes pushed yesterday broke stem's integ tests. In particular GETCONF is broke. Repro is simple. Here's an example...

% ./tor-prompt

>>> GETINFO config-text
250+config-text=
ControlPort 9051
CookieAuthentication 1
DataDirectory /home/atagar/.tor
ExitPolicy reject *:*
HiddenServiceStatistics 0
Log notice stdout
SocksPort 0
.
250 OK

>>> GETCONF ControlPort
250 ControlPort

Thanks!

Child Tickets

Change History (8)

comment:1 Changed 5 weeks ago by nickm

  • Keywords regression added
  • Milestone set to Tor: 0.3.0.x-final

Hm, probably caused by #20956.

comment:2 Changed 5 weeks ago by dgoulet

Plausible and to that effect. I've seen this on my relay last night when upgrading. It didn't cause any issues except that warning as far as I can tell.

Jan 24 02:54:10.000 [warn] Can't return context-sensitive 'dirport' on its own

comment:3 Changed 5 weeks ago by nickm

  • Summary changed from Recent changes broke GETCONF to Recent changes broke GETCONF *Port

Yeah; we need to make it so asking for FooPort works again.

comment:4 Changed 5 weeks ago by nickm

  • Owner set to nickm
  • Status changed from new to assigned

comment:5 Changed 4 weeks ago by nickm

  • Status changed from assigned to needs_review

Okay, I think I have a fix. It makes it so *all* LINELIST_S options are queryable individually from the controller interface. It's not useful to get most of them out-of-context, but it isn't harmful. What do we think of my branch bug21300 ?

comment:6 Changed 4 weeks ago by dgoulet

Tested on my relay, it's fixing the warning I reported earlier. Code lgtm. atagar should ack though once stem tests passes.

Thanks!

comment:7 Changed 4 weeks ago by atagar

Hi there, Nick can run the stem integ tests just as well as I can. It's just a tor make target. No point in me pulling and compiling. :P

comment:8 Changed 4 weeks ago by nickm

  • Resolution set to fixed
  • Status changed from needs_review to closed

I can confirm that this makes the getconf failures go away, so merging it.

Thanks all!

Note: See TracTickets for help on using tickets.