Opened 9 years ago

Closed 8 years ago

#2131 closed defect (fixed)

Windows Requires Login As Administrator

Reported by: swt1951swt Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia 0.2.10
Severity: Keywords: Administrator, Vista, crashes
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

in vista, could not make tor work when not logged in as administrator, not even if i run vidalia as an administrator. internet search indicated that many others have had this problem. recommend adding this to the documentation or fixing it

Child Tickets

Attachments (1)

VidaliaLog-10.29.2010.txt (1.3 KB) - added by swt1951swt 9 years ago.
log produced when polipo doesn't run

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by chiiph

Component: Tor ClientVidalia
Owner: set to chiiph
Type: enhancementdefect
Version: Vidalia 0.2.10

Can you provide a detail log so we can know when/where Vidalia is running into problems?

Thanks

comment:2 Changed 9 years ago by swt1951swt

i should have mentioned that, from a user perspective, 1) having to log in as an administrator isn't a problem, 2) having to log in as an administrator makes sense, and 3) having to log in as an administrator may be desirable. so i vote for just adding a comment about it to the documentation. but, if this is truly an accidental feature that you want to remedy, i'll upload some log data to you. thanks

comment:3 Changed 9 years ago by Sebastian

This sounds quite accidental. Administrator privileges shouldn't be required for Vidalia.

Changed 9 years ago by swt1951swt

Attachment: VidaliaLog-10.29.2010.txt added

log produced when polipo doesn't run

comment:4 Changed 9 years ago by swt1951swt

the original problem, produced over and over ad nauseam, occurred when i had installed vidalia under a non-admin account. then, tor could sometimes complete a circuit and sometimes not, but i could never verify that i was using tor. unfortunately, i didn't save the logs. since then, i uninstalled vidalia under my non-admin account and reinstalled it under my admin account, where everything works. i just went back to my non-admin account and ran the vidalia that i installed in my admin account. if i just run vidalia as non-admin, polipo doesn't run (it's not listed as a running process and firefox indicates "the proxy server is refusing connections"). if i run vidalia as admin, everything is fine. attached is a detailed vidalia log for the instance where polipo doesn't run. if it would help, i will uninstall vidalia under my admin account and reinstall it under my non-admin account to try to reproduce the original problem along with log entries

comment:5 Changed 9 years ago by arma

Owner: changed from chiiph to arma
Status: newaccepted

I wonder exactly which component of the bundle doesn't work. The log you posted is for Tor, and it shows that Tor is working just fine.

Does the Tor Browser Bundle work for you?

comment:6 Changed 9 years ago by arma

Owner: changed from arma to chiiph
Status: acceptedassigned

(ugh. stupid trac.)

comment:7 Changed 9 years ago by phobos

I don't have vista, but I cannot create this in windows 7 as a non-admin user. TBB works fine in all cases. Installing the vidalia bundle wants admin credentials because it tries to install to protected directories. But once the vidalia bundle is installed, it works normally as a non-admin user.

comment:8 Changed 9 years ago by swt1951swt

update on original problem report : i can now run from non-admin account if i run privoxy manually and then run vidalia manually ; cannot get vidalia to run privoxy (says it can't open the privoxy config file) ; don't have this problem from my admin account ; this is not a problem for me, but since i brought it up, i'll provide any info that might help ; and, yes, i am able to verify proper functioning of privoxy and tor when i run privoxy and vidalia manually

comment:9 Changed 9 years ago by arma

What bundle are you using that includes Privoxy rather than Polipo?

comment:10 Changed 9 years ago by swt1951swt

i downloaded vidalia bundle and privoxy separately, installed both, but then set vidalia to work with privoxy instead of polipo

comment:11 in reply to:  description Changed 9 years ago by gnd

Keywords: Administrator Vista crashes added

Replying to swt1951swt:

in vista, could not make tor work when not logged in as administrator, not even if i run vidalia as an administrator. internet search indicated that many others have had this problem. recommend adding this to the documentation or fixing it.

I too have this same problem but with TorBundle!! ( It may have something to do with upgrading to FireFox 4.0): I am logged in as Administrator. Videllia comes up tor comes up tor crashes. Videllia generates an error and will not bring up tor to work. crashed and will not work until i right clicked on the tor icon and clicked on open as administrator. The log message is unaware of the cause not being "opened as administrator". Help offers no help either.

I am not very good with computers but since i STUMBLED on this solution I hope to share it with TOR & Videllia. I was logged in as administrator but Tor bundle required opening with ADMIN via right click on the icon!

The solution that needs to be discussed is a message that states:
"Error: user is trying to use tor without admin access and TOR will fail without admin permissions. RIGHT CLICK on icon and select run in administrator mode."

Expected results:
operating systems greys out ans says program wants permission to run with admin privilages.
Videllia comes up
Tor comes up
Firefox (tor bundled) comes up
"you are connected to tor" message appears on Firefox.

And this is what happens for me using this mode.

What I am not sure about is how to make TOR ALWAYS BOOT IN ADMINISTRATOR MODE FROM ADMINISTRATOR (OR OTHERWISE except by right clicking & clicking on open as admin), nor how to get Videllia to recognize lack of administrator privileges.

Hope this helps.

I also look forward to Encrypted email.
P.S. Cryptography is very very important to freedom of communications. It is just that most implementations require knowledge of cryptology that I quite frankly cannot understand or keep track of. I am afraid that for the likes of me to use encrypted email as I would wish to, I really need en-cyphered communications to work like a toaster: 1 button and one knob (Key length set at 8192) and let the network to decide how to get it to the recipient and let TOR or Mozilla or Thunderbird decide What is necessary for it to work in a secure way non-detectible way and leaving no traces. The advantage to everyone else is that if EVERYBODY is using ungodly strong cyphers by default then only the recipient and God himself will be able to decipher it in this century or so. Then it will be unfeasible to stop it! Except possibly with quantum computing(maybe just a myth).

For the most part torbundle works like a toaster!!!

Thanks TOR!!!!!
Thanks videllia!!!
Thanks polipo!

A clear and Start over button That kills non responsive TOR processes might be nice too but it might also need to be opened as admin!

Again thanks to all!
GND

comment:12 Changed 9 years ago by gnd

I don't know how to revert Firefox to test it either.

comment:13 Changed 8 years ago by chiiph

Resolution: fixed
Status: assignedclosed

I can't reproduce this with the latest TBB on Windows 7. Please reopen if the problem persists.

Note: See TracTickets for help on using tickets.