Opened 2 years ago

Closed 2 years ago

#21335 closed defect (worksforme)

Updating to 6.5 changes security settings to "Low" without notification

Reported by: ggavilan Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I updated from 6.0.7 to 6.5 today, and I had the security levels to High, and after the update they where set to Low without any type of notification, enabling JS which I had disabled in High.

I guess it's related to "Bug 20264: Change security slider to 3 options".

Most users won't realize that their security settings have been lowered.

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by gk

Priority: Very HighHigh
Severity: CriticalMajor
Status: newneeds_information

I just tested with a clean 6.0.7 and updated to 6.5. My slider is still on "High". Can you reproduce the bug on your system with a clean 6.0.7? (you'll find it on https://archive.torproject.org/tor-package-archive/torbrowser/6.0.7/) We had other users on the blog that mentioned the transition from "Medium-High" or "Medium-Low" to "Medium" worked. So, I wonder what's up with your issue.

comment:2 Changed 2 years ago by mcs

For what it's worth, I also was unable to reproduce this problem.
On OSX, I set a clean TB 6.0.7 installation to High and it was still at High after I updated to TB 6.5. I also tested Medium-High -> Medium.

comment:3 Changed 2 years ago by ggavilan

Resolution: worksforme
Status: needs_informationclosed

Tried to reproduce again several times, was unable to do so. Thanks guys!

Note: See TracTickets for help on using tickets.