Opened 2 years ago

Closed 22 months ago

#21370 closed enhancement (duplicate)

Onionoo should be more robust against unexpected data

Reported by: iwakeh Owned by: metrics-team
Priority: Medium Milestone: Onionoo-1.6.0
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Copied from comment 15 in #20440:

Onionoo should be a little more robust against unexpected data in the in/archive/ directory. It could simply skip the unrecognized descriptor and carry on with the next descriptor. That's s/break/continue/ in this line.

Good idea!

This also needs a test implementation and at least a change to the log statement that just one descriptor is skipped.

Child Tickets

Change History (6)

comment:1 Changed 2 years ago by iwakeh

Milestone: Onionoo-1.2.0

comment:2 Changed 2 years ago by iwakeh

Milestone: Onionoo-1.2.0Onionoo-1.3.0

comment:3 Changed 2 years ago by iwakeh

Milestone: Onionoo-1.3.0Onionoo-1.4.0

comment:4 Changed 23 months ago by iwakeh

Milestone: Onionoo-1.4.0Onionoo-1.5.0

comment:5 Changed 22 months ago by iwakeh

Milestone: Onionoo-1.5.0Onionoo-1.6.0

Move to next milestone in order to accommodate interim release.

comment:6 Changed 22 months ago by karsten

Resolution: duplicate
Status: newclosed

Looks like a near-duplicate of #20412. Closing.

Note: See TracTickets for help on using tickets.