Opened 2 years ago

Closed 2 years ago

#21387 closed defect (duplicate)

Enabling the bookmarks bar can allow websites to fingerprint you

Reported by: Dbryrtfbcbhgf Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

go to http://whatsmy.browsersize.com/and check the size of the browser window.
then click on view in torbrowser and enable the bookmark bar. the go to http://whatsmy.browsersize.com/
again and the size of your browser window will change from the default values. This can allow websites to uniquely identify users that have bookmark bar enabled.

before enabling bookmark bar.
Browser window width: 1000
Browser window height: 500
Screen width: 1000
Screen height: 500
Screen color depth: 24

After enabling bookmark bar.
Browser window width: 1000
Browser window height: 477
Screen width: 1000
Screen height: 477
Screen color depth: 24

tor browser version tested.
6.5 (based on Mozilla Firefox 45.7.0)

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by Dbryrtfbcbhgf

Here is a video showing the issue.
http://sendvid.com/k840iy0x

comment:2 Changed 2 years ago by Dbryrtfbcbhgf

This also effects 7.0a1 (based on Mozilla Firefox 45.7.0). Here are the results when I follow the above steps.

Before enabling bookmark bar.
Browser window width: 867
Browser window height: 520
Screen width: 867
Screen height: 520
Screen color depth: 24
/
After enabling bookmark bar.
Browser window width: 867
Browser window height: 500
Screen width: 867
Screen height: 500
Screen color depth: 24

comment:3 Changed 2 years ago by gk

Milestone: Tor: 0.2.9.x-final
Resolution: duplicate
Status: newclosed
Version: Tor: 0.2.9.9

Duplicate of #16456.

Note: See TracTickets for help on using tickets.