Opened 3 years ago

Closed 3 years ago

#21401 closed defect (duplicate)

Sandbox exits and fails to launch firefox on fedora 64

Reported by: glassbox Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Running on a fedora 64 virtual machine:

[jammy@my-vm sandbox]$ ./sandboxed-tor-browser
2017/02/06 11:21:55 launch: Starting.
2017/02/06 11:21:55 launch: Connecting to the Tor network.
2017/02/06 11:21:56 tor: Feb 06 11:21:56.776 [notice] Tor 0.2.9.9 (git-56788a2489127072) running on Linux with Libevent 2.0.22-stable, OpenSSL 1.0.2j and Zlib 1.2.8.
2017/02/06 11:21:56 tor: Feb 06 11:21:56.776 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
2017/02/06 11:21:56 tor: Feb 06 11:21:56.776 [notice] Read configuration file "/home/amnesia/tor/etc/torrc".
2017/02/06 11:21:56 tor: Feb 06 11:21:56.782 [notice] Opening Control listener on /home/amnesia/tor/data/control
2017/02/06 11:21:56 tor: Feb 06 11:21:56.782 [notice] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
2017/02/06 11:21:56 tor: Feb 06 11:21:56.000 [notice] Parsing GEOIP IPv4 file /home/amnesia/tor/etc/geoip.
2017/02/06 11:21:57 tor: Feb 06 11:21:57.000 [notice] Parsing GEOIP IPv6 file /home/amnesia/tor/etc/geoip6.
2017/02/06 11:21:57 tor: Feb 06 11:21:57.000 [notice] Bootstrapped 0%: Starting
2017/02/06 11:21:57 tor: Feb 06 11:21:57.000 [notice] Delaying directory fetches: DisableNetwork is set.
2017/02/06 11:21:57 tor: Feb 06 11:21:57.000 [notice] New control connection opened.
2017/02/06 11:21:57 tor: Taking ownership of the tor process
2017/02/06 11:21:57 tor: Feb 06 11:21:57.000 [notice] Opening Socks listener on /home/amnesia/tor/data/socks
2017/02/06 11:21:58 tor: Feb 06 11:21:58.000 [notice] Bootstrapped 80%: Connecting to the Tor network
2017/02/06 11:21:58 tor: Feb 06 11:21:58.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
2017/02/06 11:21:59 tor: Feb 06 11:21:59.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
2017/02/06 11:22:00 tor: Feb 06 11:22:00.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
2017/02/06 11:22:00 tor: Feb 06 11:22:00.000 [notice] Bootstrapped 100%: Done
2017/02/06 11:22:00 tor: Opened SOCKS passthrough listener: 127.0.0.1:9150
2017/02/06 11:22:00 launch: Starting Tor Browser.

Everything is fine until:

2017/02/06 11:22:00 firefox: Can't mount proc on /newroot/proc: Operation not permitted
2017/02/06 11:22:00 launch: Complete.
2017/02/06 11:22:01 tor: Feb 06 11:22:01.000 [notice] Catching signal TERM, exiting cleanly.
2017/02/06 11:22:01 failed to accept control conn: accept unix /run/user/1000/sandboxed-tor-browser/control: use of closed network connection
2017/02/06 11:22:01 failed to accept SOCKS conn: accept unix /run/user/1000/sandboxed-tor-browser/socks: use of closed network connection

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by yawning

Resolution: duplicate
Status: newclosed

This is probably a duplicate of #21077, which is a Xen specific Linux kernel bug. If you aren't using Xen, then please re-open it.

Supposedly unmounting /proc/xen exists as a workaround, but may break other things.

Note: See TracTickets for help on using tickets.