Opened 4 years ago

Closed 4 years ago

#21412 closed defect (not a bug)

Atlas incorrectly reporting MyFamily

Reported by: saint Owned by: irl
Priority: Low Milestone:
Component: Metrics/Relay Search Version:
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently, Atlas outputs the contents of MyFamily under "Alleged family members" instead of "Alleged family group" or fetching the other nodes in that declared family.

Example: https://atlas.torproject.org/#details/94541F30DE462C066F4504D397C10776DFAD475F denotes "saint" as a family member instead of the family itself.

Child Tickets

Change History (4)

comment:1 in reply to:  description ; Changed 4 years ago by saint

Replying to saint:

Currently, Atlas outputs the contents of MyFamily under "Alleged family members" instead of "Alleged family group" or fetching the other nodes in that declared family.

Incidentally, Atlas is also not reading/displaying NodeFamily information.

comment:2 in reply to:  1 Changed 4 years ago by arma

Replying to saint:

Incidentally, Atlas is also not reading/displaying NodeFamily information.

NodeFamily is a client-side hack to make your Tor client build paths differently. It isn't a way for the relay to advertise anything. Can you figure out what in the documentation confused you, and open a new ticket for fixing that? :)

comment:3 in reply to:  description Changed 4 years ago by arma

Replying to saint:

Currently, Atlas outputs the contents of MyFamily under "Alleged family members" instead of "Alleged family group" or fetching the other nodes in that declared family.

Example: https://atlas.torproject.org/#details/94541F30DE462C066F4504D397C10776DFAD475F denotes "saint" as a family member instead of the family itself.

Ah ha -- there is no such thing as a family group.

The MyFamily lines get put into the relay descriptor like so:

family saint

and for two relays to be in the same family, they need to both list each other. Otherwise some random relay could add itself to your family, inducing clients to avoid using both relays in the same circuit, which could become bad if it's done in bulk.

comment:4 Changed 4 years ago by karsten

Resolution: not a bug
Status: newclosed

I didn't look at the relay in question, but from the conversation above it seems like there's no bug in Atlas. Please re-open if there is.

Note: See TracTickets for help on using tickets.