Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2142 closed defect (duplicate)

[Error] Bug:

Reported by: navajo Owned by: chiiph
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

![03:14:35] Tor Software Error - The Tor software encountered an internal bug. Please report the following error message to the Tor developers at bugs.torproject.org: ""

Oct 30 !04:02:28.555 [Error] Bug: buffers.c:269: buf_shrink_freelists: Assertion (*chp)->next failed; aborting.

Child Tickets

Change History (5)

comment:1 Changed 9 years ago by chiiph

Component: VidaliaTor Client
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by chiiph

This is duplicate of ticket #1125.

comment:3 Changed 9 years ago by Sebastian

Nice, finally we have some idea what the actual bug is for all those "" reports. Looks related to bugs #977 #1125 #1178 #1033 #1868 for the actual bug, and related to #2063 #1998 for the empty Vidalia message.

The likely cause (some kind of weird corruption) for the Tor bug might also explain why Vidalia doesn't get a message delivered and just displays a "" to the user.

comment:4 Changed 9 years ago by nickm

fwiw, we just fixed #1125, I think. Have a look at the most recent comments there.

comment:5 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.