Opened 9 years ago

Closed 8 years ago

#2144 closed defect (duplicate)

TorCtl Concurrency Bugs

Reported by: atagar Owned by: mikeperry
Priority: Medium Milestone:
Component: Torctl Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

To quote #tor-dev...
22:33 < atagar> mikeperry: There seems to be a couple concurrency bugs with shutting down torctl: (1) when connect fails to authenticate it needs to close the failed torctl instance to stop its main loop from continuing and (2) close joins on the event thread, but not self._thread causing occasional shutdown issues like [1]

14:14 < mikeperry> atagar: is there a trac entry for this, or when the scrollback is gone, or when this pastebin expires, this will be history?

14:16 < atagar> mikeperry: Heh, can do if you'd like. I'd be happy to make patches but I can't reliably repro the issue so testing would be a pita. I was hoping that you'd be able to either say "yup, there's a obvious bug here" or "nah, you're missing X".

14:17 < atagar> the second issue seems to occure around 1% of the time or less (guess I could try a script that starts/stops torctl a bunch and see if that does the trick...)

14:19 < atagar> NightMonkey seemed to be able to reliably repro the first issue, but he's usually not around and his repro seems to be platform dependent (gentoo)

[1] atagar@fenrir:~/Desktop/arm$ ./arm -e 2
Exception in thread TorLoop (most likely raised during interpreter shutdown):
Traceback (most recent call last):

File "/usr/lib/python2.6/threading.py", line 525, in bootstrap_inner
File "/usr/lib/python2.6/threading.py", line 477, in run
File "/home/atagar/Desktop/arm/src/TorCtl/TorCtl.py", line 675, in _loop
File "/home/atagar/Desktop/arm/src/TorCtl/TorCtl.py", line 824, in _read_reply

<type 'exceptions.TypeError'>: 'NoneType' object is not callable

Child Tickets

Change History (2)

comment:1 Changed 9 years ago by atagar

Owner: set to mikeperry
Status: newassigned

comment:2 Changed 8 years ago by atagar

Resolution: duplicate
Status: assignedclosed

Pretty sure that this is a duplicate of 2412 and 2812. Resolving.

Note: See TracTickets for help on using tickets.