Opened 2 years ago

Last modified 5 months ago

#21444 needs_information defect

Webcam light flashes when I open NoScript menu

Reported by: ChatTor Owned by: tbb-team
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Critical Keywords:
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I click the "NoScript" icon in Tor Browser Bundle version 6.5, my webcam light flashes for a split second, almost like it records something for a split second. I've been having this problem for a while, and decided it's time to file a bug report for this.

I'm running Gentoo kernel version 4.9.6, I have installed the Tor Browser Bundle with the layman repo git://github.com/MeisterP/torbrowser-overlay.git, and my webcam is a USB device, works properly using V4L kernel drivers, and is considered a UVC input device.

I can record a video of this happening if anybody thinks it would be helpful.

Thanks,
ChatTor

Child Tickets

Change History (8)

comment:1 Changed 2 years ago by ChatTor

Keywords: TBB added; TB removed

comment:2 Changed 2 years ago by cypherpunks

Component: - Select a componentApplications/Tor Browser
Keywords: Tor Browser Bundle TBB removed
Owner: set to tbb-team

comment:3 Changed 2 years ago by cypherpunks

Version: Tor: unspecified

comment:4 Changed 2 years ago by yawning

Status: newneeds_information

One of the ways that package overlay installs Tor Browser isn't Tor Browser, despite the claims that it is, the other at a cursory glance is tor-browser-launcher. Can you clarify which package you installed, and also see if the issue is reproducible using an official Tor Browser download?

comment:5 Changed 2 years ago by ChatTor

I used the command layman -a torbrowser to install the torbrowser overlay. While the overlay is being added, I see the following line appear:

Running Git... # ( cd /var/lib/layman && /usr/bin/git clone git://github.com/MeisterP/torbrowser-overlay.git /var/lib/layman/torbrowser )

So I assume that's the relevant github. I ended up installing the www-client/torbrowser-launcher package from that overlay.

Also, I tried installing tor Tor Browser Bundle straight from the tor project website, and the same thing happens, even after removing the old package to ensure there was no conflict.

comment:6 Changed 2 years ago by mcs

Cc: mcs added

This does not make much sense. I hope you have already put opaque tape over your webcam....

Does this happen when clicking on other icons in Tor Browser or just the NoScript one?

If you are willing to run Firefox, can you check and see if this happens with Firefox ESR45?

https://www.mozilla.org/en-US/firefox/organizations/all/

Last edited 2 years ago by mcs (previous) (diff)

comment:7 Changed 2 years ago by ChatTor

Sorry for the delay, IRL can be busy. It doesn't seem to happen with Firefox 45.7, and my webcam is USB, so I don't need tape personally.

It doesn't make much sense to me either, but, after playing with it more, it seems that the light flickers any time a menu resembling the right-click menu is drawn (Click the NoScript icon, click the HTTPS Everywhere icon, right-clicking, hovering over the NoScript option in the right-click menu), but not for fancy menus (like when you click the 3 lines to get into Firefox's settings or when you click the gear icon in a new tab). Perhaps the bug is tied to the menu draw function of Firefox somehow? I'm not familiar with the source of Firefox, so I (unfortunately) can't be more helpful here.

Also worth mentioning, I tried removing all add-ons and restarting the browser, and the light still flashes when I right-click and the right-click menu opens. This occurs both in the body of the browser as well as the address bar part of the browser, but not when I right-click the window title area drawn by X and get my system options for things such as "Move to desktop".

Last edited 2 years ago by ChatTor (previous) (diff)

comment:8 Changed 5 months ago by traumschule

does this happen with latest TB? (when i find a minute i'll set up a vm)

Note: See TracTickets for help on using tickets.