Opened 9 years ago

Closed 16 months ago

#2150 closed defect (wontfix)

Autoconnect to a tor instance loaded after startup

Reported by: T(A)ILS developers Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version: Vidalia 0.2.10
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: anonym, intrigeri Actual Points:
Parent ID: #1247 Points:
Reviewer: Sponsor:

Description

Context

In Debian systems, Tor is launched as a daemon, which has its own user. Vidalia then connects to Tor through the control port.

Steps to reproduce the problem

  1. Start Vidalia
  2. (Re-)start the Tor daemon, e.g. a by a script triggered because the system got a new connection (this restart is required due to a tor bug #1247)

Expected result

Vidalia (re-)connects to the Tor daemon.

Actual result

Vidalia says that "Tor is not running"

Workaround

The user need to click on "Start Tor" after the daemon restart.

Child Tickets

Change History (6)

comment:1 Changed 9 years ago by chiiph

Parent ID: #1247
Type: enhancementdefect
Version: Vidalia 0.2.10

comment:2 Changed 9 years ago by promeneur

Linux Mandriva 2010.2 32 bit
kde 4.5.5
qt 4.7.1
vidalia 0.2.9

same pb
tor is set up separately inde pendantly.
it's a daemon started by the system when you start the pc
and the owner of tor is "toruser" user with "toruser" group, not the current user
which uses vidalia

comment:3 Changed 9 years ago by T(A)ILS developers

Cc: amnesia@… added

comment:4 Changed 5 years ago by intrigeri

Cc: anonym intrigeri added; amnesia@… removed

comment:5 Changed 23 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:6 Changed 16 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.