Opened 2 years ago

Closed 2 weeks ago

#21501 closed enhancement (duplicate)

implement TFO aka TCP FAST OPEN to save RTT

Reported by: acceleraTor Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Minor Keywords: tor-client tor-relay tcp-fast-open
Cc: Actual Points:
Parent ID: #16682 Points:
Reviewer: Sponsor:

Description

from current android to windows versions it is now implement. Why not make use of it?
Sure yes, Client to Guard connection would benefit the less.

Child Tickets

Change History (7)

comment:1 Changed 2 years ago by yawning

I don't think this helps the common cases in a noticeable manner.

There is one long lived TLS connection between the Client and Guard, and inter-relay links converge toward the network being a complete graph. If anything I'd expect this to have more impact on the latter.

comment:2 Changed 2 years ago by teor

Milestone: Tor: 0.3.0.x-finalTor: unspecified
Version: Tor: unspecified

comment:3 Changed 2 years ago by nickm

Keywords: tor-relay tcp-fast-open added

I guess it might help a tiny bit to do this at the exit?

comment:4 in reply to:  3 Changed 3 months ago by cypherpunks

Replying to nickm:

I guess it might help a tiny bit to do this at the exit?

Of course it will reduce latencys and feeling of connection speed. See: #16682

comment:5 Changed 3 months ago by teor

Parent ID: #16682
Resolution: duplicate
Status: newclosed

This is a duplicate of #16682: let's use the ticket that talks about the privacy risks.

comment:6 Changed 2 weeks ago by cypherpunks

Resolution: duplicate
Status: closedreopened

implementation in inter-relay and client=>guard connection seems to be without any possible privacy impacts yet. why don't just enable TFO(TCP Fast Open) in alpha testing branch for this TLS only connections?

comment:7 in reply to:  6 Changed 2 weeks ago by teor

Resolution: duplicate
Status: reopenedclosed

Replying to cypherpunks:

implementation in inter-relay and client=>guard connection seems to be without any possible privacy impacts yet. why don't just enable TFO(TCP Fast Open) in alpha testing branch for this TLS only connections?

This is a duplicate ticket, let's continue the conversation in #16682.

Note: See TracTickets for help on using tickets.