Opened 3 years ago

Closed 3 years ago

#21512 closed defect (not a bug)

Tor expert bundle does not change identity (IP) [Windows]

Reported by: x58973 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.9.9
Severity: Normal Keywords: change identity tor-client Windows
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi all,

Several days I try to change identity in the version "Tor expert bundle [Windows]"

My build tor Portable: Link

Video .AVI (IP address does not change): Link

TOR Auto Switcher: Link

When you try to change identity get the console message: "[notice] New control connection opened from 127.0.0.1." But the IP address will not be changed...

How do I send a windows command "SIGNAL NEWNYM" to change the IP address?

THX ALL.

Child Tickets

Change History (18)

comment:1 Changed 3 years ago by teor

Component: - Select a componentCore Tor/Tor
Keywords: tor-client Windows added

Hi,

Thanks for reporting this.
Please provide a text description of what you're trying to do, rather than video links.

comment:2 Changed 3 years ago by x58973

Ok,

Tor.exe works at startup "control.bat" I get the message "[notice] New control connection opened from 127.0.0.1." IP address (change identity) does not change. The same problem occurs when you use TOR Auto Switcher.

control.bat

@echo off

REM Create file with control commands
echo AUTHENTICATE> commands.txt
echo SIGNAL NEWNYM>> commands.txt
echo QUIT>> commands.txt

REM Connect to control port and issue commands
nc localhost 9151 < commands.txt

REM Delete commands file
del /Q commands.txt

NetCat I got here: Link

How do i have to proceed ?

comment:3 Changed 3 years ago by teor

What is the output when you run control.bat?

comment:4 Changed 3 years ago by x58973

I already wrote: "[notice] New control connection opened from 127.0.0.1."

It is also shown in the video.

comment:5 in reply to:  4 Changed 3 years ago by teor

Replying to x58973:

I already wrote: "[notice] New control connection opened from 127.0.0.1."

It is also shown in the video.

What is the output of nc when you run control.bat?

comment:6 Changed 3 years ago by x58973

"nc.exe" not see anything (shows no window)

comment:7 in reply to:  6 Changed 3 years ago by teor

Replying to x58973:

"nc.exe" not see anything (shows no window)

The expected output is something like:

AUTHENTICATE
250 OK
SIGNAL NEWNYM
250 OK
QUIT
250 closing connection

If you are not seeing any output, then either the window disappears before you can see it, or the command is never run.

Try opening a command shell, running those commands, and pasting the output here.

comment:8 Changed 3 years ago by x58973

I launched nc.exe and I entered the command (Unfortunately, the IP addresses have not changed) Link

Last edited 3 years ago by x58973 (previous) (diff)

comment:9 Changed 3 years ago by teor

Please use https://pastebin.debian.org and paste text in future.

What IP address do you expect to change?

What does nc output when you say:

GETINFO version

comment:10 Changed 3 years ago by x58973

"GETINFO version" > Closed nc.exe

Mozilla Firefox to configure Tor (SOCKS): Link

Run setup.bat > (Run Tor) Random IP Example: 91.197.234.102 This address is assigned to Mozilla Firefox (And I see it on the website example: whoer.net)
This IP address does not change after you enter the commands.

Last edited 3 years ago by x58973 (previous) (diff)

comment:11 in reply to:  10 Changed 3 years ago by teor

Replying to x58973:

"GETINFO version" > Closed nc.exe

What does nc output when you say:

AUTHENTICATE
GETINFO version

Mozilla Firefox to configure Tor (SOCKS): Link

Please use Tor Browser, it's much easier, and it has a built-in "new circuit for this site" command.

Run setup.bat > (Run Tor) Random IP Example: 91.197.234.102
This IP address does not change after you enter the commands.

If this is the exit IP address, then the supported way of doing this is using Tor Browser.

Or, if you want to map exits for some reason, use exitmap at:
https://github.com/NullHypothesis/exitmap

Otherwise, I don't think we can help you with programming the tor control port, sorry.

comment:12 Changed 3 years ago by teor

Resolution: not a bug
Status: newclosed

comment:13 in reply to:  12 ; Changed 3 years ago by x58973

Replying to teor:

Cmd line: localhost 9151
AUTHENTICATE
250 OK
GETINFO version 250-version=0.2.9.9 (git-56788a2489127072)
250 OK

I thought that the command "SIGNAL NEWNYM" works by creating a new identity.

And it creates a new circle of IP addresses (ENTRY, MIDDLE, EXIT) node. For existing and new connections. When using Windows Tor expert bundle can not change the IP Exit Node?

And can you explain exactly how the command works "SIGNAL NEWNYM"?

PS: Or is the problem that the command "SIGNAL NEWNYM" only works in the Tor Browser?

Thx

Last edited 3 years ago by x58973 (previous) (diff)

comment:14 Changed 3 years ago by x58973

Resolution: not a bug
Status: closedreopened

comment:15 in reply to:  13 Changed 3 years ago by teor

Status: reopenedneeds_information

Replying to x58973:

...
I thought that the command "SIGNAL NEWNYM" works by creating a new identity.

And it creates a new circle of IP addresses (ENTRY, MIDDLE, EXIT) node. For existing and new connections. When using WIndows Tor expert bundle can not change the IP Exit Node?

And can you explain exactly how the command works "SIGNAL NEWNYM"?

https://gitweb.torproject.org/torspec.git/tree/control-spec.txt#n419

The supported way of doing SIGNAL NEWNYM is with Tor Browser.
It works in Tor Browser.
It works using other control port clients, like stem:
https://gitweb.torproject.org/stem.git/

I can't help you with tor configuration or control port programming on this ticket system, because as far as I can tell there's no tor bug here: the bug is in your code.

comment:16 Changed 3 years ago by x58973

Even so, thank you for your help.

Unfortunately, if I remember Tor stem is only for Linux (Not on Windows) :-/

comment:17 Changed 3 years ago by atagar

Nope, Stem works fine under Windows. You might be confusing it with Nyx (aka arm) which doesn't.

comment:18 Changed 3 years ago by dgoulet

Resolution: not a bug
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.