Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#2152 closed defect (fixed)

Tor Wakes Up from Hibernation Day 1 of Period

Reported by: BarkerJr Owned by:
Priority: High Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

0.2.2.17

=================== BarkerJrCoast2 ===================
Nov 01 00:00:00.396 [notice] Configured hibernation. This interval began at 2010-11-01 00:00:00; the scheduled wake-up time was 2010-11-01 00:00:00; we expect to exhaust our quota for this interval around 2010-12-01 00:00:00; the next interval begins at 2010-12-01 00:00:00 (all times local)

state:
AccountingBytesReadInInterval 36379586560
AccountingBytesWrittenInInterval 36869425152
AccountingExpectedUsage 1455
AccountingIntervalStart 2010-11-01 00:00:00
AccountingSecondsActive 89886

=================== BarkerJrGarden1 ===================
Nov 01 00:00:00.849 [notice] Configured hibernation. This interval began at 2010-11-01 00:00:00; the scheduled wake-up time was 2010-11-01 00:00:00; we expect to exhaust our quota for this interval around 2010-12-01 00:00:00; the next interval begins at 2010-12-01 00:00:00 (all times local)

state:
AccountingBytesReadInInterval 52794882048
AccountingBytesWrittenInInterval 53545815040
AccountingExpectedUsage 363
AccountingIntervalStart 2010-11-01 00:00:00
AccountingSecondsActive 90000
AccountingSecondsToReachSoftLimit 90110
AccountingSoftLimitHitAt 2010-11-02 01:01:50
AccountingBytesAtSoftLimit 53687751399

state (2010-10-24):
AccountingBytesReadInInterval 53005556736
AccountingBytesWrittenInInterval 53688081408
AccountingExpectedUsage 345
AccountingIntervalStart 2010-10-01 00:00:00
AccountingSecondsActive 2008225
AccountingSecondsToReachSoftLimit 187469
AccountingSoftLimitHitAt 2010-10-03 04:04:29
AccountingBytesAtSoftLimit 53687262755

=================== BarkerJrGarden2 ===================
Nov 01 00:00:00.592 [notice] Configured hibernation. This interval began at 2010-11-01 00:00:00; the scheduled wake-up time was 2010-11-01 00:00:00; we expect to exhaust our quota for this interval around 2010-12-01 00:00:00; the next interval begins at 2010-12-01 00:00:00 (all times local)

state:
AccountingBytesReadInInterval 52916600832
AccountingBytesWrittenInInterval 53687749632
AccountingExpectedUsage 363
AccountingIntervalStart 2010-11-01 00:00:00
AccountingSecondsActive 90045
AccountingSecondsToReachSoftLimit 90045
AccountingSoftLimitHitAt 2010-11-02 01:00:45
AccountingBytesAtSoftLimit 53687749102

Child Tickets

Change History (8)

comment:1 Changed 9 years ago by nickm

Milestone: Tor: 0.2.2.x-final

comment:2 Changed 9 years ago by Sebastian

Looks like this was addressed in bc081c254afaac42 and the three prior commits?

comment:3 Changed 9 years ago by BarkerJr

This doesn't seem fixed to me. Both are 0.2.2.22 (as of Jan 29)

BarkerJrAtom1
---
Feb 01 00:00:00.631 [info] configure_accounting(): Accounting interval elapsed; starting a new one
Feb 01 00:00:00.677 [info] reset_accounting(): Starting new accounting interval.
Feb 01 00:00:00.677 [notice] Configured hibernation. This interval began at 2011-02-01 00:00:00; the scheduled wake-up time was 2011-02-01 00:00:00; we expect to exhaust our quota for this interval around 2011-03-01 00:00:00; the next interval begins at 2011-03-01 00:00:00 (all times local)
Feb 01 00:00:00.677 [notice] Hibernation period ended. Resuming normal activity.
...
Feb 11 00:38:16.109 [notice] Bandwidth soft limit reached; commencing hibernation.
Feb 11 00:38:16.109 [notice] Going dormant. Blowing away remaining connections.
Mar 01 00:00:00.023 [warn] Mismatched accounting interval: moved by 90.32%. Starting a fresh one.
Mar 01 00:00:00.189 [info] reset_accounting(): Starting new accounting interval.
Mar 01 00:00:00.189 [notice] Configured hibernation. This interval began at 2011-03-01 00:00:00; the scheduled wake-up time was 2011-03-01 00:00:00; we expect to exhaust our quota for this interval around 2011-04-01 00:00:00; the next interval begins at 2011-04-01 00:00:00 (all times local)
Mar 01 00:00:00.189 [notice] Hibernation period ended. Resuming normal activity.
...
Mar 03 05:19:18.022 [notice] Bandwidth soft limit reached; commencing hibernation.
Mar 03 05:19:18.055 [notice] Going dormant. Blowing away remaining connections.

BarkerJrAtom2
---
Feb 01 00:00:00.385 [info] configure_accounting(): Accounting interval elapsed; starting a new one
Feb 01 00:00:00.398 [info] reset_accounting(): Starting new accounting interval.
Feb 01 00:00:00.398 [notice] Configured hibernation. This interval began at 2011-02-01 00:00:00; the scheduled wake-up time was 2011-02-01 00:00:00; we expect to exhaust our quota for this interval around 2011-03-01 00:00:00; the next interval begins at 2011-03-01 00:00:00 (all times local)
Feb 01 00:00:00.398 [notice] Hibernation period ended. Resuming normal activity.
...
Feb 11 00:38:46.594 [notice] Bandwidth soft limit reached; commencing hibernation.
Feb 11 00:38:46.594 [notice] Going dormant. Blowing away remaining connections.
Mar 01 00:00:00.644 [warn] Mismatched accounting interval: moved by 90.32%. Starting a fresh one.
Mar 01 00:00:00.658 [info] reset_accounting(): Starting new accounting interval.
Mar 01 00:00:00.658 [notice] Configured hibernation. This interval began at 2011-03-01 00:00:00; the scheduled wake-up time was 2011-03-01 00:00:00; we expect to exhaust our quota for this interval around 2011-04-01 00:00:00; the next interval begins at 2011-04-01 00:00:00 (all times local)
Mar 01 00:00:00.658 [notice] Hibernation period ended. Resuming normal activity.
...
Mar 03 20:54:17.756 [notice] Bandwidth soft limit reached; commencing hibernation.
Mar 03 20:54:18.756 [notice] Going dormant. Blowing away remaining connections.

comment:4 Changed 8 years ago by nickm

Priority: normalmajor

comment:5 Changed 8 years ago by nickm

We should figure out whether bug 3020 (fixed in 0.2.2.25-alpha) might have been the cause of this too: I note the telltale "Mar 01 00:00:00.644 [warn] Mismatched accounting interval: moved by 90.32%. Starting a fresh one."

comment:6 Changed 8 years ago by Sebastian

Resolution: fixed
Status: newclosed

Looks likely. Closing this as we still have #2003 for the same issue I think. Please reopen this if it still happens

comment:7 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:8 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.