Opened 2 years ago

Closed 2 years ago

#21529 closed defect (duplicate)

Bootstrap fails if one pinned ExitNode is not running

Reported by: dgoulet Owned by:
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression?
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Some user reported that he/she pinned a single ExitNode and that relay is not running which ultimately make tor not bootstrap. (Taken from #21520)

Feb 22 00:08:35.018 [notice] Opening Socks listener on 127.0.0.1:9550
Feb 22 00:08:35.018 [notice] Opening Control listener on 127.0.0.1:9551
Feb 22 00:08:35.000 [notice] Bootstrapped 0%: Starting
Feb 22 00:08:36.000 [notice] Bootstrapped 45%: Asking for relay descriptors
Feb 22 00:08:38.000 [notice] Bootstrapped 50%: Loading relay descriptors
Feb 22 00:08:46.000 [notice] I learned some more directory information, but not enough to build a circuit: We need more microdescriptors: we have 7134/7268, and can only build 0% of likely paths. (We have 98% of guards bw, 98% of midpoint bw, and 0% of exit bw = 0% of path bw.)

This seems peculiar behavior because Tor should be able to download the consensus nevertheless through Dir Auth. or Fallback Directories? A tor without a working ExitNode is a valid Tor (hidden service client for instance) so it should bootstrap.

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by teor

This is a duplicate of #19989.
A workaround is to use two exits in the EntryNodes list.

comment:2 Changed 2 years ago by teor

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.