Opened 9 years ago

Closed 7 years ago

#2154 closed defect (not a bug)

Tor Browser crashes every time on Windows 7

Reported by: jerrycg2k10 Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Windows 7 no services packs or updates installed. Downloaded Tor Browser yesterday and tried to use it today. Vidalia is displays and appears normal as it connects, but as soon as it connects it disappears and evidently everything closes. Task manager shows no related programs or processes running.

Also, I have another copy of Firefox installed on the computer. When I tried to use it after this first happened, I found that it had been configured to use a proxy server as if Tor had configured it rather than the portable version in the Tor Browser directory.

I can find no logs created by Tor/Vidalia, and a scan through Windows events found nothing. (Although I'm not yet very familiar with the Windows 7 event log.)

The file I downloaded is tor-browser-1.3.12_en-US.exe.

Any suggestions would be appreciated, and I would be happy to supply any additional information that may be needed.

thanks,
JG

Child Tickets

Change History (5)

comment:1 Changed 9 years ago by phobos

Version: Torbutton: 1.3

Do you have a log from either tor or vidalia? I've tested tbb on win7 and it works just fine. Tbb will not reconfigure any other applications. Did you perhaps install the vidalia-bundle before trying tbb?

comment:2 in reply to:  1 Changed 9 years ago by jerrycg2k10

Replying to phobos:

Do you have a log from either tor or vidalia? I've tested tbb on win7 and it works just fine. Tbb will not reconfigure any other applications. Did you perhaps install the vidalia-bundle before trying tbb?

I discovered a problem with Windows automatic updates so involved it took until yesterday to fix it. When it ran after that, Tor started up with no problem and ran normally, so it looks like it was a windows problem. I'm afraid I have no clue what the interaction might have been.

Sorry for the false alarm.

Thanks,
Jerry Gardner

comment:3 Changed 9 years ago by rransom

Resolution: not a bug
Status: newclosed

comment:4 Changed 7 years ago by wattor

Resolution: not a bug
Status: closedreopened

I don't think that it was a false alarm. Last year I've got a new PC with Windows 7 installed. One of the first things I've installed was the Tor-Browserbundle and Windows crashes every time I've tried it. A while ago I tried another version of the bundle - and some weeks all things seem working fine. But since some days I've the same problem again. Nearly every time I try to start it, it crashes with a BSOD. It's a heavy used PC but no other software seems to be able to crash it in this way. In another forum I've read the hint, that I've to disable Kaspersky but I don't think that this is a good solution.

comment:5 Changed 7 years ago by cypherpunks

Resolution: not a bug
Status: reopenedclosed

wattor, this bug was about tbb crash not about windows crash because tbb. And actually it was not a tbb bug at all. Read #4956 for your problem.

Note: See TracTickets for help on using tickets.