Opened 4 months ago

Closed 4 months ago

#21599 closed defect (fixed)

Make hidden service descriptor creation more consistent

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version: Tor: 0.2.7.2-alpha
Severity: Normal Keywords: tor-hs
Cc: Actual Points: 0.1
Parent ID: #21446 Points: 0.1
Reviewer: Sponsor:

Description

This cleans up #21596: now that circuit_established is reliable, it can be used during descriptor creation as well. This prevents a regression to bugs like #21594.

Child Tickets

Change History (4)

comment:1 Changed 4 months ago by teor

  • Status changed from new to needs_review
  • Version set to Tor: 0.2.7.2-alpha

Please see my branch bug21599, which includes the change it depends on from #21596.

comment:2 follow-up: Changed 4 months ago by dgoulet

  • Status changed from needs_review to needs_revision

Patch lgtm however it will conflict because that patch also has the change of remove_invalid_intro_points() I've seen in another ticket.

comment:3 in reply to: ↑ 2 Changed 4 months ago by teor

  • Status changed from needs_revision to merge_ready

Replying to dgoulet:

Patch lgtm however it will conflict because that patch also has the change of remove_invalid_intro_points() I've seen in another ticket.

No, it won't conflict with #21596 - git is smart enough to merge commits that match.

(See my branch today-in-hs for how this works.)

comment:4 Changed 4 months ago by nickm

  • Resolution set to fixed
  • Status changed from merge_ready to closed

merged to master; looks plausible.

Note: See TracTickets for help on using tickets.