Opened 7 months ago

Closed 5 months ago

#21646 closed task (implemented)

prop140/compression: Refactor "directory request" code

Reported by: nickm Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: TorCoreTeam201703, prop140
Cc: ahf Actual Points: 1
Parent ID: Points: 1
Reviewer: Sponsor: Sponsor4

Description

Our current notion of "what is a directory request" includes a bunch of fields that are strewn around directory connections and passed to different functions. It would be nice to instead have a "directory request" type that we created and passed around as appropriate. This would make it easier to test our request generation/parsing code.

Child Tickets

Change History (8)

comment:1 Changed 7 months ago by nickm

Owner: set to nickm
Status: newaccepted

comment:2 Changed 6 months ago by dgoulet

Keywords: prop140 added

comment:3 Changed 5 months ago by nickm

I've done some work in my branch dirreq, but I should look it over more and test it more before it's ready for review.

comment:4 Changed 5 months ago by ahf

Cc: ahf added

comment:5 Changed 5 months ago by nickm

Actual Points: 1
Status: acceptedneeds_review

Okay, my dirreq branch is now ready for review. It should contain no functional changes.

gitlab merge request at https://gitlab.com/nickm_tor/tor/merge_requests/17

comment:6 Changed 5 months ago by ahf

Status: needs_reviewneeds_revision

Really nice change. I like the explicit interfaces much more than the old directory_initiate_command*() interface for firing off requests. The code is much easier to read now.

I've added a couple of comments to the code.

comment:7 Changed 5 months ago by ahf

Status: needs_revisionmerge_ready

LGTM.

comment:8 Changed 5 months ago by nickm

Resolution: implemented
Status: merge_readyclosed

Thanks; merged!

Note: See TracTickets for help on using tickets.