Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2170 closed enhancement (duplicate)

Enable microdescriptors on the client side

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.2.3.1-alpha
Component: Core Tor/Tor Version:
Severity: Keywords: microdesc
Cc: Actual Points:
Parent ID: #1748 Points:
Reviewer: Sponsor:

Description

All the logic is in place to let clients fetch microdescriptor consensuses and use microdescriptors in place of descriptors... except for the code to let them turn it on.

See branch "microdesc-use" in my public repository for the implementation.

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by nickm

Status: newneeds_review

Incidentally, we may want to hold off merging this till just after 0.2.3.1-alpha is out, so that servers have a chance to get onto 0.2.3.1-alpha before clients start looking for such servers to give them microdescriptors.

Some do-they-matter issues:

  • Does use of microdescriptors or lack thereof leak whether you are a bridge?

comment:2 Changed 9 years ago by nickm

Resolution: duplicate
Status: needs_reviewclosed

Ooops, this is a duplicate of #1756. Closing.

comment:3 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.