Opened 9 months ago

Closed 26 hours ago

#21702 closed defect (duplicate)

No Data Available message for bandwidth graphs

Reported by: kat5 Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Atlas Version:
Severity: Normal Keywords: metrics-2018
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Atlas displays "No Data Available" instead of bandwidth graphs for some relays.The relays have uptimes of days or months; the consensus/probability graphs are displayed.

Examples:

https://atlas.torproject.org/#details/336887A3689503AEA4AF2A4EA964AB907AE18280

https://atlas.torproject.org/#details/28B6C3352C1352AE2F4A46CDD914C2B29BA660D5

Child Tickets

Change History (5)

comment:1 Changed 9 months ago by karsten

14:31:37 < karsten> kat5: looks like a bug in atlas, possibly related to those relays 
                    still reporting bandwidth data for the "3 days" and "1 week" 
                    graphs that are not available anymore.

comment:2 Changed 9 months ago by cypherpunks

The browser console gives the following TypeError and backtrace

TypeError: model.get(...) is undefined graph.js:32:29
parseHistory/</<() graph.js:32
forEach() self-hosted:208
b.forEach() underscore-min.js:11
parseHistory/<() graph.js:21
forEach() self-hosted:208
b.forEach() underscore-min.js:11
parseHistory() graph.js:11
graphModel<.parse_bw_data() graph.js:130
mainDetailsView<.render/<.success() main.js:191
graphModel<.lookup_bw/xhr<() graph.js:120
f.Callbacks/n() jquery-min.js:2
f.Callbacks/o.fireWith() jquery-min.js:2
w() jquery-min.js:4
.send/d() jquery-min.js:4

comment:3 Changed 8 weeks ago by karsten

Keywords: metrics-2018 added

comment:4 Changed 8 weeks ago by karsten

Owner: changed from irl to metrics-team
Status: newassigned

comment:5 Changed 26 hours ago by irl

Resolution: duplicate
Status: assignedclosed

This is a duplicate of #21658.

Note: See TracTickets for help on using tickets.