Changes between Initial Version and Version 1 of Ticket #21704, comment 8


Ignore:
Timestamp:
Mar 14, 2017, 11:56:19 AM (2 years ago)
Author:
gk
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #21704, comment 8

    initial v1  
    1616> Shortly, Windows won't break until ESR59 too, because it was required for MSVS 2015u2 and opt-in Rust (msvs target available only).
    1717
    18 Have you tried to compile it with non-MSVC? If you e.g. use mingw-w64 you'd see pretty fast that that statement is wrong: https://bugzilla.mozilla.org/show_bug.cgi?id=1331335. Thus, we need SSE2 support unless we want to specifically patch code for non-SSE2 support. In addition to that, not following Mozilla here has the great risk of getting security fixes that rely in their Windows variant on SSE2. We'd have to backport those fixes as well while which I think we don't want to risk.
     18Have you tried to compile it with non-MSVC? If you e.g. use mingw-w64 you'd see pretty fast that that statement is wrong: https://bugzilla.mozilla.org/show_bug.cgi?id=1331335. Thus, we need SSE2 support unless we want to specifically patch code for non-SSE2 support. In addition to that, not following Mozilla here has the great risk of getting security fixes that rely in their Windows variant on SSE2. We'd have to backport those fixes as well while being under time pressure which I think we don't want to risk.