Opened 4 years ago

Closed 4 years ago

#21711 closed defect (duplicate)

try to build tor-browser.git with clang's Code Flow Integrity option

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arthuredelstein)

I tried to build tor-browser.git using -fsanitize=cfi and I ran into the following bug that was reported recently:
http://lists.llvm.org/pipermail/llvm-dev/2017-February/109861.html

Fortunately, it seems this bug has been fixed in clang 4.0. Binaries for clang 4.0.0 should be available in a few days so I will try again then.

See https://clang.llvm.org/docs/ControlFlowIntegrity.html

Child Tickets

Change History (2)

comment:1 Changed 4 years ago by arthuredelstein

Description: modified (diff)

comment:2 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #20361.

Note: See TracTickets for help on using tickets.