Opened 3 years ago

Closed 3 years ago

#21718 closed defect (fixed)

git-rw.torproject.org is out of sync with git.torproject.org for webwml repo

Reported by: gk Owned by: tor-gitadm
Priority: High Milestone:
Component: Internal Services/Service - git Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I pushed 772b536efe59183858215b233d7464cf4608655a to the webwml repo on git-rw.torproject.org on Thursday but git.torproject.org is still on 53dfbb59c7b095e7fe73e7a74e10d1d9418e1adc.

This has the nasty consequence that Tor Browser users still think 6.5, 7.0a1, and 7.0a1-hardened are still up-to-date as https://www.torproject.org/projects/torbrowser/RecommendedTBBVersions is apparently tied to git.torproject.org and does not get rebuilt when a new relevant commit lands on git-rw.torproject.org.

Child Tickets

Change History (6)

comment:1 Changed 3 years ago by teor

This also breaks cloning the repository:

$ git clone https://git.torproject.org/tor-browser.git/
Cloning into 'tor-browser'...
remote: Counting objects: 5042617, done.
remote: Compressing objects: 100% (2208/2208), done.
remote: Total 5042617 (delta 1652), reused 0 (delta 0)
Receiving objects: 100% (5042617/5042617), 1.16 GiB | 318.00 KiB/s, done.
Resolving deltas: 100% (4125718/4125718), done.
warning: remote HEAD refers to nonexistent ref, unable to checkout.
$ cd tor-browser/
$ git checkout master
error: pathspec 'master' did not match any file(s) known to git.
$ git branch

(git branch lists no branches)

comment:2 Changed 3 years ago by teor

Hmm, this is broken on git-rw, maybe it's a separate issue:

$ mv tor-browser tor-browser-broken
$ git clone --reference tor-browser-broken --dissociate git@git-rw.torproject.org:tor-browser.git
Checking connectivity: 5042617, done.
Counting objects: 5042617, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (865560/865560), done.
Writing objects: 100% (5042617/5042617), done.
Total 5042617 (delta 4125718), reused 5042617 (delta 4125718)
warning: remote HEAD refers to nonexistent ref, unable to checkout.

comment:3 Changed 3 years ago by teor

Oops, just ignore me, there's no master branch. Total newbie.

comment:4 in reply to:  1 Changed 3 years ago by boklm

Replying to teor:

This also breaks cloning the repository:

$ git clone https://git.torproject.org/tor-browser.git/
Cloning into 'tor-browser'...
remote: Counting objects: 5042617, done.
remote: Compressing objects: 100% (2208/2208), done.
remote: Total 5042617 (delta 1652), reused 0 (delta 0)
Receiving objects: 100% (5042617/5042617), 1.16 GiB | 318.00 KiB/s, done.
Resolving deltas: 100% (4125718/4125718), done.
warning: remote HEAD refers to nonexistent ref, unable to checkout.
$ cd tor-browser/
$ git checkout master
error: pathspec 'master' did not match any file(s) known to git.
$ git branch

This is expected. The repository does not have a master branch, so you need to checkout one after cloning.

(git branch lists no branches)

This is because there is no local branches after cloning, but git branch -r should list some remote ones.

comment:5 Changed 3 years ago by Sebastian

The desync was probably caused by a kernel update on git.tpo. Fixed now, thanks for reporting

comment:6 Changed 3 years ago by Sebastian

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.