Opened 9 months ago

Closed 5 months ago

#21732 closed defect (fixed)

Stop the Meek Tor Browser opening links or documents on macOS

Reported by: teor Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: meek
Cc: brade, mcs, dcf Actual Points:
Parent ID: #17670 Points:
Reviewer: Sponsor:

Description

Sometimes, the meek Tor Browser instance opens links or documents on macOS, when those links or documents should be opened in the regular Tor Browser.

This has happened in the past on macOS, but we don't know whether it is still reproducible.

Child Tickets

Change History (5)

comment:1 Changed 9 months ago by dcf

Keywords: meek added

Do you mean, when double-clicking on a link or document in the Finder? Or is it just opening links and documents randomly?

comment:2 Changed 9 months ago by mcs

Cc: brade mcs added

comment:3 in reply to:  1 Changed 9 months ago by teor

Replying to dcf:

Do you mean, when double-clicking on a link or document in the Finder? Or is it just opening links and documents randomly?

Users have reported it happening when opening links from Adium.
I think I've also seen it in the Finder.

comment:4 Changed 6 months ago by teor

Opening links and documents with Tor Browser as the default browser works in 7.0.1, probably because #21724 was fixed. That means that this bug is probably fixed as well.

Do you want to close this, mcs or dcf?

comment:5 in reply to:  4 Changed 5 months ago by dcf

Cc: dcf added
Resolution: fixed
Status: newclosed

Replying to teor:

Opening links and documents with Tor Browser as the default browser works in 7.0.1, probably because #21724 was fixed. That means that this bug is probably fixed as well.

Do you want to close this, mcs or dcf?

Thanks for the update. I'll close it.

Note: See TracTickets for help on using tickets.