Opened 2 years ago

Closed 2 years ago

#21899 closed defect (not a bug)

Address setting ignoring IPv6

Reported by: ItsNannerpuss Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.7.6
Severity: Normal Keywords: ipv6
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

According to the torrc man page:

"Address: The IP address or fully qualified domain name of this server (e.g. moria.mit.edu)."

In torrc, set the Address to an IPv6 address and port using standard notation:

Address [1234:5678::01:1234]


The tor server starts up, and doesn't appear to give any relevant warnings, but log output suggests tor is ignoring the address setting and guessing anyway.

Apr 09 15:50:52.000 [notice] Guessed our IP address as 1.2.3.4 (source: 5.6.7.8).

This server is configured only with IPv6 settings for tor, and the goal is to have it ignore any IPv4 addresses present on the host, so this behavior is undesirable.

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by cypherpunks

Tor relays require IPv4 addresses for the foreseeable future.
You can not setup a tor relay without IPv4.

comment:2 Changed 2 years ago by gk

Component: - Select a componentCore Tor/Tor

comment:3 Changed 2 years ago by dgoulet

Milestone: Tor: 0.2.7.x-finalTor: unspecified
Resolution: not a bug
Status: newclosed

Address appears to not support IPv6 (see resolve_my_address()).

What you want here is probably ORPort [address:]PORT|auto [flags] and make sure to set the flag IPv6Only. I think that would resolve your issue. Give it a try!

Ex: ORPort [1234:5678::01:1234]:auto IPv6Only

Note: See TracTickets for help on using tickets.