Opened 16 months ago

Closed 5 months ago

#21926 closed defect (fixed)

Still had 1 address policies cached at shutdown

Reported by: arma Owned by:
Priority: Low Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.10
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On moria1, each time I do a controlled shutdown, I see:

Apr 12 11:17:49.154 [warn] Still had 1 address policies cached at shutdown.     
Apr 12 11:17:49.154 [warn]   1 [13]: reject *4:*                                

This is on git master (0.3.1.0-alpha-dev), but it's been happening for some months.

See also #672 and #16539 for the previous instances of this bug.

Child Tickets

Attachments (1)

000a.zip (57.5 KB) - added by teor 11 months ago.
zip of authority data dir with this bug

Download all attachments as: .zip

Change History (12)

comment:1 Changed 16 months ago by nickm

Milestone: Tor: 0.3.2.x-final
Priority: MediumLow
Severity: NormalMinor

comment:2 Changed 16 months ago by arma

May 07 22:16:25.499 [warn] Still had 12 address policies cached at shutdown.
May 07 22:16:25.499 [warn]   1 [27]: reject 107.181.174.84:*
May 07 22:16:25.499 [warn]   2 [1239]: reject *4:*
May 07 22:16:25.499 [warn]   3 [45]: reject 10.0.0.0/8:*
May 07 22:16:25.499 [warn]   4 [27]: accept *4:443
May 07 22:16:25.499 [warn]   5 [18]: accept *4:*
May 07 22:16:25.499 [warn]   6 [45]: reject 172.16.0.0/12:*
May 07 22:16:25.499 [warn]   7 [45]: reject 127.0.0.0/8:*
May 07 22:16:25.499 [warn]   8 [45]: reject 169.254.0.0/16:*
May 07 22:16:25.499 [warn]   9 [27]: accept *4:80
May 07 22:16:25.499 [warn]   10 [45]: reject 192.168.0.0/16:*

comment:3 Changed 16 months ago by arma

Version: Tor: 0.3.0.6

Confirmed that bug appears consistently on Tor 0.3.0.6 as well.

comment:4 Changed 15 months ago by ln5

I just saw this on a dirauth running 0.3.0.6 when killing it:

May 16 09:32:26.000 [notice] Catching signal TERM, exiting cleanly.
May 16 09:32:27.000 [warn] Still had 10 address policies cached at shutdown.
May 16 09:32:27.000 [warn]   1 [3]: reject 107.181.174.84:*
May 16 09:32:27.000 [warn]   2 [3]: reject 169.254.0.0/16:*
May 16 09:32:27.000 [warn]   3 [3]: reject 10.0.0.0/8:*
May 16 09:32:27.000 [warn]   4 [3]: reject 127.0.0.0/8:*
May 16 09:32:27.000 [warn]   5 [3]: accept *4:443
May 16 09:32:27.000 [warn]   6 [3]: reject 192.168.0.0/16:*
May 16 09:32:27.000 [warn]   7 [3]: reject 172.16.0.0/12:*
May 16 09:32:27.000 [warn]   8 [3]: accept *4:80
May 16 09:32:27.000 [warn]   9 [3]: reject 0.0.0.0/8:*
May 16 09:32:27.000 [warn]   10 [170]: reject *4:*

comment:5 Changed 15 months ago by arma

Here's our hint:

$ grep 107.181.174.84 cached-*
cached-consensus:r NeelTorExitUSWest 1GF1SHwzLMYC99GkTXunM0jGxJ4 oJ8kgsI8e732ZTLPiAklOcWJxyA 2017-05-21 02:38:29 107.181.174.84 443 80
cached-microdesc-consensus:r NeelTorExitUSWest 1GF1SHwzLMYC99GkTXunM0jGxJ4 2017-05-21 02:38:29 107.181.174.84 443 80

It's in the consensus but moria1 doesn't have a descriptor for it!

Here's something interesting in my info-level log:

May 21 01:10:40.108 [info] dirserv_router_get_status(): Descriptor from router $D46175487C332CC602F7D1A44D7BA73348C6C49E~NeelTorExitUSWest at 107.181.174.84 has an Ed25519 key, but the <rsa,ed25519> keys don't match what they were before.

In fact, I have an info-level log line like that once a minute in my log, forever.

comment:6 in reply to:  5 Changed 15 months ago by arma

Replying to arma:

It's in the consensus but moria1 doesn't have a descriptor for it!

[...]

In fact, I have an info-level log line like that once a minute in my log, forever.

I've opened that one as #22349. It might be related to this ticket but it's not the same.

comment:7 Changed 15 months ago by arma

Wonder if #22370 is related.

comment:8 Changed 15 months ago by arma

Resolution: duplicate
Status: newclosed

Closing since #22370 looks like the root cause.

comment:9 Changed 11 months ago by teor

Milestone: Tor: 0.3.2.x-finalTor: 0.3.3.x-final
Resolution: duplicate
Status: closedreopened
Version: Tor: 0.3.0.6Tor: 0.3.0.10

I have seen this on a modified 0.3.0.10 with the #22370 patch (but also a bunch of extra privcount patches, none of which deal with address policies).

Is this still happening on an unmodified master?

Changed 11 months ago by teor

Attachment: 000a.zip added

zip of authority data dir with this bug

comment:10 Changed 5 months ago by arma

I don't think I've been seeing this one lately. Did we fix it in some other bugfix, and this is now a duplicate of whatever-ticket-that-was?

comment:11 Changed 5 months ago by teor

Milestone: Tor: 0.3.3.x-finalTor: 0.3.2.x-final
Resolution: fixed
Status: reopenedclosed

I haven't seen it on 0.3.2.9, so let's call it fixed in 0.3.2 or 0.3.1

Note: See TracTickets for help on using tickets.