Opened 2 years ago

Closed 2 years ago

#21960 closed defect (fixed)

Linux 7.0a3 bundles are not reproducible anymore (omni.ja files differ)

Reported by: gk Owned by: tbb-team
Priority: Very High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: ff52-esr, tbb-7.0-must-alpha, TorBrowserTeam201704
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor4

Description

There are differences in the omni.ja files if built in our Gitian environment. Noted first in comment:8:ticket:20426 it seems not to be rbm specific. I opened https://bugzilla.mozilla.org/show_bug.cgi?id=1356900 on Mozilla's side

Child Tickets

Change History (6)

comment:1 Changed 2 years ago by cypherpunks

Hmm, why didn't you try ticket:20426#comment:15 for consistency with rbm?

comment:2 in reply to:  1 ; Changed 2 years ago by boklm

Replying to cypherpunks:

Hmm, why didn't you try ticket:20426#comment:15 for consistency with rbm?

This is unrelated to this issue.

comment:3 Changed 2 years ago by boklm

It seems we might want to disable startup cache generation like mozilla did: https://bugzilla.mozilla.org/show_bug.cgi?id=1351071

This patch applies correctly on our branch:
https://github.com/mozilla/gecko-dev/commit/b7af545070788b5a50cb1752e878a1de79e37ed3.patch

I have started 2 builds in rbm with this patch to check if it removes the diff in omni.ja.

comment:4 in reply to:  3 Changed 2 years ago by boklm

Replying to boklm:

I have started 2 builds in rbm with this patch to check if it removes the diff in omni.ja.

And the 2 linux64 builds produced the same bundle.

comment:5 in reply to:  2 Changed 2 years ago by cypherpunks

Replying to boklm:

Replying to cypherpunks:

Hmm, why didn't you try ticket:20426#comment:15 for consistency with rbm?

This is unrelated to this issue.

Yes, it is just to reduce the diff.
Mozillians mentioned that buildid could be the root cause. But deterministic mode for mozjar is a general solution. Of course, it's easier just to disable startup cache pre-compilation/pre-generation.

comment:6 Changed 2 years ago by gk

Resolution: fixed
Status: newclosed

Thanks. This is commit ec0b55bdfb638c63f30116b19583456632ad708d on tor-browser-52.1.0esr-7.0-1 and will make it into the final 7.0a3.

Note: See TracTickets for help on using tickets.