Opened 8 months ago

Closed 8 months ago

#21992 closed enhancement (duplicate)

Consensus Health: how many medians does each bandwidth authority control?

Reported by: teor Owned by: tom
Priority: Medium Milestone:
Component: Metrics/Consensus Health Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When we change the bandwidth authorities, we want to know what impact this has on their measurements.

This matters most for:

  • new bandwidth authorities, and
  • changing the location of bandwidth authorities or bandwidth servers

It would help us if we knew for each relay:

  • the median bandwidth authority: the bandwidth authority that made the relay's median measurement

This tells us which authority has control over the measurement. One way to implement this would be to make the median bold in each relay's bandwidth row.

It would also help us if we knew for each bandwidth authority:

  • how many relays have its measurement as the median

One way to implement this is to add to the "Bandwidth scanner status" table:
https://consensus-health.torproject.org/#bwauthstatus

longclaw 7845 measured 1569 median
gabelmoo 7419 measured 1484 median

It would also be helpful to have a graph of how this changes over time.

Child Tickets

Change History (3)

comment:1 Changed 8 months ago by teor

Resolution: duplicate
Status: newclosed

Looks like this is a duplicate of #21882. Oops.

comment:2 in reply to:  description Changed 8 months ago by tom

Resolution: duplicate
Status: closedreopened

Replying to teor:

It would help us if we knew for each relay:

  • the median bandwidth authority: the bandwidth authority that made the relay's median measurement

This tells us which authority has control over the measurement. One way to implement this would be to make the median bold in each relay's bandwidth row.

In the detailed table there is now a bwauth=XXX line on the consensus column to say this explicitly.


It would also help us if we knew for each bandwidth authority:

  • how many relays have its measurement as the median

One way to implement this is to add to the "Bandwidth scanner status" table:
https://consensus-health.torproject.org/#bwauthstatus

longclaw 7845 measured 1569 median
gabelmoo 7419 measured 1484 median

This can/should be added. Reopening this ticket to track this particular item.

It would also be helpful to have a graph of how this changes over time.

We have a graph now, in #21882.

comment:3 Changed 8 months ago by tom

Resolution: duplicate
Status: reopenedclosed

Actually, no I'm going to close this as a duplicate of #21993 which asks for a more detailed table.

Note: See TracTickets for help on using tickets.