Opened 9 years ago

Closed 8 years ago

#2201 closed defect (duplicate)

Torbutton (incorrectly) prevents reloads.

Reported by: katmagic Owned by: mikeperry
Priority: High Milestone:
Component: TorBrowserButton Version: Torbutton: 1.3.0-alpha
Severity: Keywords:
Cc: the.magical.kat@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I sometimes get messages like "[11-18 16:20:00] Torbutton NOTE: NO ORIGIN! Blockng request for: [scrubbed]" in the Firefox error console when I try to reload or navigate through tab history, though navigating through the use of links still works. Also, other extensions are unable to reload tabs. This bug appears to be linked to specific tabs, and persists through (but isn't caused by) a TorButton toggle.

Child Tickets

Change History (12)

comment:1 Changed 9 years ago by nickm

Component: - Select a componentTorbutton
Owner: set to mikeperry

comment:2 Changed 9 years ago by katmagic

I'm using the following extensions:

  • Adblock Plus (1.3.1)
  • Certificate Patrol (1.4)
  • Cookie Monster (1.0.5)
  • Firebug (1.5.4)
  • FlashGot (1.2.5)
  • Ghostery (2.4.2)
  • HTTPS Everywhere (a derivative of b4f083d)
  • NoScript (2.0.7)
  • Perspectives (4.0)
  • Read It Later (2.0.6)
  • RequestPolicy (0.5.16)
  • Tab Mix Plus (0.3.8.4)
  • Torbutton (1.3.0-alpha)

comment:3 Changed 9 years ago by rransom

Please use about:config to set extensions.torbutton.loglevel to 3. This (or any other value less than 4) will turn off safe logging, so that the log message will contain the URL of the request which Torbutton blocked.

I received one of these messages shortly after installing Torbutton 1.3.0-alpha and the other extensions you listed, but it didn't prevent a page from being loaded.

comment:4 Changed 9 years ago by rransom

I could not reproduce the ‘NO ORIGIN’ message again, or reproduce this bug, in 30 to 60 minutes of browsing with the above extensions installed in Firefox 3.6.12 on Windows (katmagic was using Fedora 14).

I suspect that this problem is caused by Tab Mix Plus, because that is the only extension (other than Firebug, which I believe is innocent here) in katmagic's list that should manipulate tabs or their properties.

A previous ticket (#1392) describes an apparently Linux-specific conflict of Tab Mix Plus (unspecified version) with Torbutton 1.2.5 and other addons, but I have not done enough testing to be certain that this bug is Linux-specific or would not eventually appear on Windows.

comment:5 Changed 9 years ago by mikeperry

Priority: normalmajor

comment:6 Changed 9 years ago by katmagic

This is occurring much more frequently now (with 1.3.1-alpha). It appears that the problem is that ContentPolicy.shouldLoad() (at src/components/cssblocker.js:145 as of g5e74e1d) is getting a null requestOrigin argument. I'm not sure why this would be so; unfortunately, documentation of the matter is rather sparse. It also seems that ContentPolicy.should_load is set when it shouldn't be.

comment:7 Changed 9 years ago by katmagic

Err, the last sentence makes no sense at all. Please disregard it.

comment:8 Changed 8 years ago by rransom

Summary: TorButton (incorrectly) prevents reloads.Torbutton (incorrectly) prevents reloads.

This bug occurred again with Torbutton 1.3.2-alpha in Firefox 4.0 (final) on 'Windows 7', with the following other extensions installed and enabled:

  • Firebug 1.7X.0b1
  • Greasemonkey 0.9.1
  • HTTPS-Everywhere (katmagic's treeview branch) 0.9.9.treeview.3
  • NoScript 2.0.9.8
  • RequestPolicy 0.5.19

I did not have 'Tab Mix Plus' installed, so it is not the cause of this bug.

comment:9 Changed 8 years ago by mikeperry

Component: TorbuttonTorBrowserButton

I noticed that this behavior can be triggered if you have turned off referers either through torbutton, through another addon, or directly through firefox. Is this the case for either of you?

comment:10 Changed 8 years ago by katmagic

Cc: the.magical.kat@… added

Yes. I've disabled referers completely through Torbutton.

comment:11 in reply to:  10 Changed 8 years ago by mikeperry

Replying to katmagic:

Yes. I've disabled referers completely through Torbutton.

Can you try temporarily enabling them, just to confirm this is the problem?

comment:12 Changed 8 years ago by mikeperry

Resolution: duplicate
Status: newclosed

We have a user reporting this same issue in #3429, confirming it is specific to enabling/disabling referer headers.

I am going to dup this bug to hers, which is more concise and specific.

Note: See TracTickets for help on using tickets.