Opened 5 weeks ago

Closed 4 weeks ago

#22034 closed defect (fixed)

GETINFO extra-info/digest/<digest>

Reported by: olaf.selke@… Owned by: dgoulet
Priority: High Milestone: Tor: 0.2.9.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.3-alpha
Severity: Normal Keywords: regression, control, 029-backport, 030-backport
Cc: Actual Points:
Parent ID: Points: 0.1
Reviewer: Sponsor:

Description

Hello,

retrieving extra info data from the control port don't work for me in tor-0.2.9.3-alpha and later.

GETINFO extra-info/digest/<digest>
leads to the error message
552 Unrecognized key "extra-info/digest/<digest>"

It worked in tor-v0.2.8.9 and before.

kind regards Olaf

Child Tickets

Change History (5)

comment:1 Changed 5 weeks ago by dgoulet

  • Component changed from - Select a component to Core Tor/Tor
  • Keywords regression control added
  • Milestone set to Tor: 0.3.1.x-final
  • Priority changed from Medium to High

comment:2 Changed 5 weeks ago by dgoulet

  • Keywords 029-backport 030-backport added
  • Owner set to dgoulet
  • Points set to 0.1
  • Status changed from new to assigned

This was introduced in 568dc27a19 (tor-0.2.9.1-alpha).

See branch: bug22034_031_01

This should be backported up to 029 because this is a regression of a control port command that can't be used anymore.

comment:3 Changed 5 weeks ago by dgoulet

  • Status changed from assigned to needs_review

comment:4 Changed 5 weeks ago by catalyst

Patch looks good to me. I added a regression test in https://gitlab.com/argonblue/tor/merge_requests/4, if someone would like to review that.

comment:5 Changed 4 weeks ago by nickm

  • Milestone changed from Tor: 0.3.1.x-final to Tor: 0.2.9.x-final
  • Resolution set to fixed
  • Status changed from needs_review to closed

Both lgtm; I'm going to take the fix in 0.2.9 and the test in 0.3.1.

(Also remember: when you're doing a fix that you'd like to be applied to 0.2.9, please base it on the 0.2.9 branch.)

Note: See TracTickets for help on using tickets.