Opened 2 years ago

Closed 2 years ago

#22036 closed defect (duplicate)

Tor Browser Windows Installer overwrites bridge configuration

Reported by: blockflare Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Bug description: Tor Browser Windows Installer overwrites bridge configuration

Steps to reproduce:

  1. Install the stable Tor Browser release, and choose the usual Desktop where the Tor Browser file will be.
  2. Open the Tor Browser and configure special bridges from bridges.torproject.org.
  3. Close the Tor Browser and now run the Tor Browser installation for the alpha release, choose the default Desktop location.
  4. Launch the Tor Browser and go to Onion Icon > Tor Network Settings.

Actual result: Bridge configuration was overwritten: there are no bridges.

Expected result: Bridge configuration shouldn't be overwritten by the installer.

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by cypherpunks

Didn't you see the warning (about overwriting) that it is an installer and not an updater?

comment:2 Changed 2 years ago by gk

Resolution: duplicate
Status: newclosed

The installer is explicitly warning that your old Tor Browser will be overwritten. It seems to me that included bridge configuration etc. as well. While we could work around those things I feel that's not a good approach as it sets the expectations wrong and is thus error-prone and confusing. Just use a separate directory for now. I think we might be able to avoid your problem, though, with #18367. Marking this as a duplicate of it.

Note: See TracTickets for help on using tickets.