Opened 2 years ago

Closed 2 years ago

#22044 closed defect (fixed)

When I use the search box in the upper right it defaults to using youtube (on macOS)

Reported by: Dbryrtfbcbhgf Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff52-esr, tbb-7.0-must-alpha, TorBrowserTeam201705R
Cc: mcs, brade, arthuredelstein, gk Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

when I use the search box in the upper right it defaults to using youtube instead of duckduckgo.
macOS 10.12.4 (16E195)
TBB 7.0a3

Child Tickets

Change History (11)

comment:1 Changed 2 years ago by catalyst

I observe similar behavior on macOS 10.10.5 but haven't investigated further.

comment:2 in reply to:  description Changed 2 years ago by gk

Status: newneeds_information

Replying to Dbryrtfbcbhgf:

when I use the search box in the upper right it defaults to using youtube instead of duckduckgo.
macOS 10.12.4 (16E195)
TBB 7.0a3

Hm. This seems to work on my Linux box. Which locale are you using?

comment:3 Changed 2 years ago by Dbryrtfbcbhgf

macOS 10.12.4 (16E195)

comment:4 Changed 2 years ago by catalyst

Deleted ~/Library/Application Support/TorBrowser-Data, deleted TorBrowser.app. Reinstalled 7.0a3 from TorBrowser-7.0a3-osx64_en-US.dmg. Search still defaults to YouTube for me.

comment:5 Changed 2 years ago by catalyst

I just rechecked a freshly installed 6.5.2 from TorBrowser-6.5.2-osx64_en-US.dmg (after deleting TorBrowser-Data) and it defaults to DuckDuckGo as expected.

comment:6 Changed 2 years ago by gk

Cc: mcs brade added
Keywords: ff52-esr tbb-7.0-must added
Status: needs_informationassigned
Version: Tor: 0.3.0.5-rc

Thanks for testing. This does not happen on Windows either which makes me wondering whether that is a macOS-only issue as #21879 with the same underlying root cause.

comment:7 Changed 2 years ago by gk

Keywords: tbb-7.0-must-alpha added; tbb-7.0-must removed

Moving tickets onto our alpha radar.

comment:8 Changed 2 years ago by gk

Summary: when I use the search box in the upper right it defaults to using youtube.When I use the search box in the upper right it defaults to using youtube (on macOS)

comment:9 Changed 2 years ago by mcs

Cc: arthuredelstein gk added
Keywords: TorBrowserTeam201705 added
Owner: changed from tbb-team to mcs

comment:10 Changed 2 years ago by mcs

Keywords: TorBrowserTeam201705R added; TorBrowserTeam201705 removed
Status: assignedneeds_review

The difference on OSX is due to https://bugzilla.mozilla.org/show_bug.cgi?id=1126722.
But the real problem is that we are not setting the default search engine correctly: browser.search.defaultenginename needs to contain an URL. This is because the getter for originalDefaultEngine, which is defined in browser/app/profile/000-tor-browser.js, uses nsIPrefBranch.getComplexValue() to retrieve the pref value. The solution is to use a data: URL for the value (Mozilla definesbrowser.search.defaultenginename.US that way). Here is a patch:
https://gitweb.torproject.org/user/brade/tor-browser.git/commit/?h=bug22044-01&id=a6a714a4541b3821267558c8c0a5ef725a91331a

comment:11 Changed 2 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me, thanks. This is commit e6b99c78fdc1800988537c73ef13e75b56c28b3e on tor-browser-52.1.0esr-7.0-2.

Note: See TracTickets for help on using tickets.