Opened 2 years ago

Closed 22 months ago

#22063 closed task (fixed)

Document that only the first qualified search term applies

Reported by: cypherpunks Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Copied from ticket:21366#comment:14 so this task isn't forgotten:

The spec says: "If the same parameter is specified more than once, only the first parameter value is considered." Now, the search term is only given once, but the qualified search terms are treated as if the user passed values to keys matching search qualifiers. And the second contact parameter is simply dropped. This is expected behavior that we might be able to document better.

Child Tickets

Change History (7)

comment:1 Changed 2 years ago by karsten

Status: newneeds_review

How's this?

comment:2 Changed 2 years ago by cypherpunks

Status: needs_reviewmerge_ready

LGTM.

comment:3 Changed 23 months ago by karsten

Status: merge_readyneeds_review

Thanks for reviewing, but I'd prefer a non-anonymous member of the metrics team to review this patch, too. :)

comment:4 Changed 23 months ago by iwakeh

Milestone: Onionoo-1.4.0
Status: needs_reviewmerge_ready

Looks good and can be part of the next milestone.

comment:5 Changed 23 months ago by karsten

Component: Metrics/OnionooMetrics/Metrics website

Thanks for looking! I can even merge it without waiting for a release, because it's now going into metrics-web. I'll do that tomorrow, unless there are objections.

comment:6 Changed 23 months ago by iwakeh

Milestone: Onionoo-1.4.0

True. Milestone removed.

comment:7 Changed 22 months ago by karsten

Resolution: fixed
Status: merge_readyclosed

Merged and deployed. Closing.

Note: See TracTickets for help on using tickets.