Opened 2 years ago

Closed 2 years ago

#22064 closed task (wontfix)

Deprecate qualified search terms in the search parameter

Reported by: cypherpunks Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The discussion in #21366 made it clear that qualified search terms aren't as good as the regular parameters.

  • They are a weak duplicate of functionality offered by the regular parameters.
  • There is no support for spaces unlike the regular parameters.
  • Not all parameters are supported as qualified search terms.
  • It places too much functionality into one parameter (look at the size of the search parameter paragraph compared to the other parameters at https://onionoo.torproject.org/#methods).

FWICT the regular parameters offer more functionality than the qualified search terms so the later can safely be deprecated without loss of functionality.

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by cypherpunks

Type: defecttask

comment:2 Changed 2 years ago by nusenu

I don't see why you would want to remove it without implementing an extended atlas search as mentioned here https://trac.torproject.org/projects/tor/ticket/21366#comment:8
to provide a replacement for current functionality first.
And even then you would break existing links.

..but I'm all for it if that makes extended searches in atlas more likely to happen - which I guess is not the case.

Last edited 2 years ago by nusenu (previous) (diff)

comment:3 Changed 2 years ago by karsten

Resolution: wontfix
Status: newclosed

The benefit of having qualified search terms in Onionoo is that applications like Atlas don't have to provide their own extended search. And if they had, they'd probably all doing it differently, making it difficult for users to switch from one to another. There's a reason to have this code in a single place. And if an application like Atlas wants to do things differently, they can just do it. Atlas could simply filter all qualified search terms and process them differently before passing parameters to Onionoo.

I'd rather want to improve qualified search terms rather than take them out because they're not powerful enough. Closing as won't fix. Thanks anyway for putting in the thoughts, and feel free to open tickets for making qualified search terms more powerful.

Note: See TracTickets for help on using tickets.