Opened 2 years ago

Closed 2 years ago

#22104 closed defect (fixed)

Adjust #19837 for ff52-esr (update our content policy whitelist)

Reported by: cypherpunks Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff52-esr, tbb-regression, TorBrowserTeam201706R
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

No controls are visible and

[...] TypeError: this.scrubber.valueChanged is not a function videocontrols.xml:962:29

Child Tickets

Attachments (1)

avctrls.png (1015 bytes) - added by cypherpunks 2 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 2 years ago by gk

Status: newneeds_information

How can I reproduce this: Which operating system are you using and which website are you trying to load?

comment:2 Changed 2 years ago by cypherpunks

Status: needs_informationnew

STR: https://ia600201.us.archive.org/1/items/OrsonWellesMrBruns/381030.ogg
If you don't see OS, test it on Windoze ;)

comment:3 in reply to:  2 Changed 2 years ago by gk

Status: newneeds_information

Replying to cypherpunks:

STR: https://ia600201.us.archive.org/1/items/OrsonWellesMrBruns/381030.ogg
If you don't see OS, test it on Windoze ;)

Works for me on my Windows 7 machine. Do you have steps to reproduce that? Does this happen with a freshly downloaded Tor Browser 7.0a3 (settings kept to the default ones)?

comment:4 Changed 2 years ago by cypherpunks

Hmm, seems to be e10s off only. Confirmed on Win XP.

comment:5 in reply to:  4 ; Changed 2 years ago by gk

Replying to cypherpunks:

Hmm, seems to be e10s off only. Confirmed on Win XP.

Works for me as well on my Windows 7 machine. I set browser.tabs.remote.autostart.2 to false, restarted Tor Browser and clicked the link. The controls are still visible. So, hrm.

Changed 2 years ago by cypherpunks

Attachment: avctrls.png added

comment:6 in reply to:  5 Changed 2 years ago by cypherpunks

Replying to gk:

Replying to cypherpunks:

Hmm, seems to be e10s off only. Confirmed on Win XP.

Works for me as well on my Windows 7 machine. I set browser.tabs.remote.autostart.2 to false, restarted Tor Browser and clicked the link. The controls are still visible. So, hrm.

This is really hrm, because your STR gives

on my Windows 7 machine (the same as on XP).

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:7 Changed 2 years ago by cypherpunks

Keywords: ff52-esr added
Owner: changed from tbb-team to yawning
Status: needs_informationassigned

yawning, we need you to update the whitelist, while TBB devs are lurking for other bugs :)
(Upgrading to "chrome://global/content/bindings/videocontrols.css", "chrome://global/skin/media/videocontrols.css", etc)

comment:8 Changed 2 years ago by mcs

Cc: tbb-team added
Owner: changed from yawning to mcs

I am updating the whitelist along with other followup work for #22459.

comment:9 Changed 2 years ago by mcs

Summary: Adjust #19837 for ff52-esrAdjust #19837 for ff52-esr (update our content policy whitelist)

comment:10 Changed 2 years ago by mcs

Keywords: TorBrowserTeam201706R added; TorBrowserTeam201705 removed
Status: assignedneeds_review

Here is a patch that expands the whitelist:
https://gitweb.torproject.org/user/brade/torbutton.git/commit/?h=bug22104-01

Kathy and I decided to use a regex pattern match for the items under chrome://global/skin/media because there are a lot of items there that need to be whitelisted. I don't think using regex will slow things down too much and it will be less fragile, e.g., currently things break when Mozilla adds an image and we don't have test cases that exposes everything that needs to be whitelisted for audio/video playback.

comment:11 Changed 2 years ago by arthuredelstein

I just tested the video file and it looks good. The code also looks good to me.

comment:12 Changed 2 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Applied to master: commit 46947ad2a818a89643d75ca2397feb39fc6ef8c3 (and even the login text filed on Trac are working again ;) ).

Note: See TracTickets for help on using tickets.