Opened 2 years ago

Closed 2 years ago

#22152 closed defect (fixed)

make-test-network-all fails hidden service tests

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.1.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor:

Description

Tor 0.3.1 with the latest chutney master often fails the hidden service tests.

These are some of the most timing-dependent chutney tests, so it could be that, or we might have broken hidden services in our recent patches.

This could be an issue with chutney or tor, we should check tor 0.3.0.6 and 0.2.9.10 and chutney 2016 to work out which versions are affected.

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by teor

Status: newneeds_information

This issue appears intermittently: all the tests work for me sometimes, other times some fail.

People who have this issue should try the latest chutney master (>=3a3c1d5).
It fixes 2 potential causes for this issue: #20409 and #22134.

A third potential cause is fixed in #21903 in my branch no-dns-rebased, but we're waiting for feedback on tor-dev before merging it to master.

But I think the issue is actually how we do HSDir fetches in small networks.
There's no way we should try the same relay twice in the same second.
And we shouldn't call it failed if we do.

This seems like another instance of the "6 quick onion address requests fail" issue. (I can't find the older ticket right now.)

May 08 16:01:50.000 [info] connection_ap_handshake_rewrite_and_attach: Got a hidden service request for ID 'dyatgmmalsazdj3g'
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'vf76is5yzugo5kq2ixxxq2et7xwzvpbf', auth type 0, and descriptor cookie '[none]' to hidden service directory $E405E0806A9BCF8BCCBB966C193EE8E886BEBFED~test002r at 127.0.0.1
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'vf76is5yzugo5kq2ixxxq2et7xwzvpbf', auth type 0, and descriptor cookie '[none]' to hidden service directory $3766BFE2BC2F5147E0891792B9F8332711192A68~test000a at 127.0.0.1
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'vf76is5yzugo5kq2ixxxq2et7xwzvpbf', auth type 0, and descriptor cookie '[none]' to hidden service directory $F39F89059329D489F594263CF6B6952038A47E5E~test004r at 127.0.0.1
May 08 16:01:50.000 [info] pick_hsdir: Could not pick one of the responsible hidden service directories, because we requested them all recently without success.
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'v7qtmkl4vr2fb4huf3ew2xretauesjp2', auth type 0, and descriptor cookie '[none]' to hidden service directory $E405E0806A9BCF8BCCBB966C193EE8E886BEBFED~test002r at 127.0.0.1
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'v7qtmkl4vr2fb4huf3ew2xretauesjp2', auth type 0, and descriptor cookie '[none]' to hidden service directory $F39F89059329D489F594263CF6B6952038A47E5E~test004r at 127.0.0.1
May 08 16:01:50.000 [info] pick_hsdir: Could not pick one of the responsible hidden service directories, because we requested them all recently without success.
May 08 16:01:50.000 [info] directory_get_from_hs_dir: Sending fetch request for v2 descriptor for service 'dyatgmmalsazdj3g' with descriptor ID 'v7qtmkl4vr2fb4huf3ew2xretauesjp2', auth type 0, and descriptor cookie '[none]' to hidden service directory $3766BFE2BC2F5147E0891792B9F8332711192A68~test000a at 127.0.0.1
May 08 16:01:50.000 [info] pick_hsdir: Could not pick one of the responsible hidden service directories, because we requested them all recently without success.
May 08 16:01:50.000 [info] pick_hsdir: Could not pick one of the responsible hidden service directories, because we requested them all recently without success.
May 08 16:01:50.000 [info] fetch_v2_desc_by_addr: Could not pick one of the responsible hidden service directories to fetch descriptors, because we already tried them all unsuccessfully.

comment:2 Changed 2 years ago by teor

This is like #15937. Again.

comment:3 Changed 2 years ago by teor

Another open related bug is #18564.

comment:4 Changed 2 years ago by teor

Resolution: fixed
Status: needs_informationclosed

This appears to be fixed in master now.

Note: See TracTickets for help on using tickets.