Opened 5 months ago

Closed 4 months ago

#22160 closed enhancement (duplicate)

Display address lists better

Reported by: cypherpunks Owned by: irl
Priority: Medium Milestone:
Component: Metrics/Atlas Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With the addition of the exit addresses field in #22147 some relays now have address fields with more than two addresses. For example https://atlas.torproject.org/#details/D5D6DBED4BEB90DB089AC1E57EA3A13B9B8AA769 has four exit addresses. These are displayed on one line which makes them almost run into the second column.

Child Tickets

Change History (3)

comment:1 Changed 5 months ago by cypherpunks

Using paragraphs (with p tags) for each address does not work because paragraphs have a bottom margin which separates them from each other.

Using separate dd tags for each address (which is allowed according to MDN) has a similar issue that is caused by custom styling. A patch to remove the custom styling was added to #21752 but didn't pass the first review. I hope it passes the second review because it would make using multiple dd tags possible and make the fix for this ticket easier.

comment:2 Changed 4 months ago by cypherpunks

Parent ID: #22147
Type: defectenhancement

This work is now being done in #22147.

comment:3 Changed 4 months ago by irl

Parent ID: #22147
Resolution: duplicate
Status: newclosed

Clean up #22147.

Note: See TracTickets for help on using tickets.