Opened 9 years ago

Closed 9 years ago

#2222 closed defect (duplicate)

Download process stops - only fraction of file is downloaded

Reported by: alexnv Owned by:
Priority: Low Milestone:
Component: Polipo Version: Polipo: 1.0
Severity: Keywords: download process break
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

What happens:

  1. Start download (from file hosting)
  2. Speed ok, download progress bar is filling
  3. Some time passed...(no alerts)
  4. Speed = 0, a fraction of file is on disk.

Notice:

  1. I tried to download using Tor 0.2.1.26 and 0.2.1.27 different files from different hosts

with almost the same result: 60-65 mb downloaded on disk

  1. When downloading without Tor (Tor not started),

using Google chrome browser, all is ok.

System parameters:
1) OS Windows XP 5.1.2600
2) Antivirus Avira (webGuard off, firewall off)
3) Windows firewall is off
4) Event ID 4226 Patcher applied
5) Mozilla adjusted:
network.http.keep-alive.timeout:600 (300ms default is OK usually, but 600 is better.)
network.http.max-persistent-connections-per-proxy:16 (Default is 4)
network.http.pipelining:true (Default- false. Some old HTTP/1.0 servers can't handle it.)
network.http.pipelining.maxrequests:8 (No default)
network.http.proxy.keep-alive:true (Default- true, but double check)
network.http.proxy.pipelining:true (Default- false) - See NOTE1 below.

QUESTION:
What can be done to fix the problem?


Child Tickets

Change History (5)

comment:1 Changed 9 years ago by arma

Component: Tor ClientPolipo
Priority: criticalminor
Version: Tor: 0.2.1.26Polipo: 1.0

I believe this is a polipo bug. Try taking polipo (the http proxy in your bundle) out of the loop and see if things get better. You can do that by going to Torbutton preferences and unclicking "use polipo". More generally, though, Tor is not designed for downloading huge files. So it is not entirely a bug that your huge downloads aren't working for you. :)

comment:2 in reply to:  1 ; Changed 9 years ago by alexnv

Dear Sir,

1) That file was only 300 mb (too huge for Tor?)
2) Please consider this:

When download actually stops (in browser: 0 bytes/sec, unknown time remaining), the Vidalia Bandwidth Usage graph shows that the traffic still goes on, with considerable pace (40 kb/sec).
As counter shows, more than 100mb were downloaded after the browser showed that it stopped.
All that data goes "somewhere", but is not attached to the file.

So, it seems that the bug is not a minor one.

Replying to arma:

I believe this is a polipo bug. Try taking polipo (the http proxy in your bundle) out of the loop and see if things get better. You can do that by going to Torbutton preferences and unclicking "use polipo". More generally, though, Tor is not designed for downloading huge files. So it is not entirely a bug that your huge downloads aren't working for you. :)

comment:3 in reply to:  2 ; Changed 9 years ago by arma

Replying to alexnv:

When download actually stops (in browser: 0 bytes/sec, unknown time remaining), the Vidalia Bandwidth Usage graph shows that the traffic still goes on, with considerable pace (40 kb/sec).
As counter shows, more than 100mb were downloaded after the browser showed that it stopped.
All that data goes "somewhere", but is not attached to the file.

Yep. The data is silently thrown out by polipo.

comment:4 in reply to:  3 Changed 9 years ago by alexnv

How can I change polipo settings (for example, chunkHighMark, objectHighMark)
to download 300mb files?

Replying to arma:

Replying to alexnv:

When download actually stops (in browser: 0 bytes/sec, unknown time remaining), the Vidalia Bandwidth Usage graph shows that the traffic still goes on, with considerable pace (40 kb/sec).
As counter shows, more than 100mb were downloaded after the browser showed that it stopped.
All that data goes "somewhere", but is not attached to the file.

Yep. The data is silently thrown out by polipo.

comment:5 Changed 9 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #1149.

Note: See TracTickets for help on using tickets.