Opened 2 years ago

Last modified 4 months ago

#22227 new defect

Netmonitor Remote Address is always 0.0.0.0 localhost

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TorBrowser 6.5.2 on Linux

To reproduce:

  1. Open Inspect Element -> Network
  2. Visit a new site, e.g. https://trac.torproject.org/
  3. Click on the request entry for the initial request in the inspector.

Expected:

The "Remote address" field shows the IP address of the site returned by the DNS query. This is the behaviour in Firefox.

Actual:

Remote address is always shown as 0.0.0.0

Child Tickets

Attachments (1)

ip_url_remote_addr_localhost.png (99.3 KB) - added by cypherpunks 2 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 2 years ago by yawning

The client's tor instance doesn't actually ever see the IP address when it connects to a FQDN, which is why 0.0.0.0 is returned. So this would be moderately annoying to fix, because it's an extra SOCKS request at a minimum (assuming RESOLVE works as expected).

Changed 2 years ago by cypherpunks

comment:2 in reply to:  1 Changed 2 years ago by cypherpunks

Replying to yawning:

The client's tor instance doesn't actually ever see the IP address when it connects to a FQDN, which is why 0.0.0.0 is returned. So this would be moderately annoying to fix, because it's an extra SOCKS request at a minimum (assuming RESOLVE works as expected).

Ok, so I can understand why it wouldn't show the real remote address if the client doesn't see the DNS response, but it also shows it as 0.0.0.0 even when browsing directly to an IP URL (see screenshot).

comment:3 Changed 2 years ago by cypherpunks

Summary: Netmonitor Gives the Wrong Remote AddressNetmonitor Shows the Wrong Remote Address

comment:4 Changed 23 months ago by cypherpunks

Summary: Netmonitor Shows the Wrong Remote AddressNetmonitor Remote Address is always 0.0.0.0 localhost

comment:5 Changed 4 months ago by cypherpunks

Still an issue in 8.0.5, also impacts the serverIPAddress field when doing HAR capture.

Note: See TracTickets for help on using tickets.