Opened 9 years ago

Closed 8 years ago

#2223 closed defect (not a bug)

Possible problem with Torbutton on New York Times Homepage?

Reported by: mwolfe Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Torbutton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I got the following error message:


Torbutton Exception in sandbox evaluation. Date hooks not applied:
[Exception... "Component returned failure code: 0x8007000e (NS_ERROR_OUT_OF_MEMORY) [nsIXPCComponents_Utils.evalInSandbox]" nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)" location: "JS frame :: chrome://torbutton/content/torbutton.js :: torbutton_hookdoc :: line 3636" data: no]


This error occurred on a PowerPC Mac running OSX 10.4.11, Firefox 3.6.6, Tor 0.2.1.26, Torbutton 1.2.5

The front page of the New York Times (www.nytimes.com) runs massive amounts of javascript, and I get so many warnings that they keep scrolling off the log faster than I can copy them. Errors are less frequent, and I found 5 when I checked:


Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIMIMEService.getTypeFromURI]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///Users/michaelwolfe/Library/Application%20Support/Firefox/Profiles/o6h6bj1j.default/extensions/%7Be0204bd5-9d31-402b-a99d-a6aa8ffebdca%7D/components/external-app-blocker.js :: anonymous :: line 126" data: no]
Source File: file:///Users/michaelwolfe/Library/Application%20Support/Firefox/Profiles/o6h6bj1j.default/extensions/%7Be0204bd5-9d31-402b-a99d-a6aa8ffebdca%7D/components/external-app-blocker.js
Line: 126 (3 times)

Error: jsonFeedCallback is not a function
Source File: http://json8.nytimes.com/pages/index.jsonp
Line: 244 (2 times)


Comment: I'm not sure if this is really a problem in Torbutton, but I posted it to OR talk several months ago and Mike asked me to create tickets so it could be studied. The errors sometimes say they occur in Torbutton, sometimes in other subroutines, so it may be that the running script hits the timeout limit at random, and then reports an error in whatever routine the timeout occurs.

Child Tickets

Change History (2)

comment:1 Changed 9 years ago by mikeperry

Yeah, this sounds like the JS on the NYT is just sucking up memory..

comment:2 Changed 8 years ago by mikeperry

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.