Opened 7 weeks ago

Closed 6 weeks ago

#22246 closed defect (fixed)

ASSERT failure on v0.3.0.6

Reported by: tmpname0901 Owned by:
Priority: High Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.6
Severity: Major Keywords: tor-hs prop224
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorR-can

Description (last modified by arma)

May 10 12:57:20.000 [err] tor_assertion_failed_(): Bug: src/common/container.c:1430: digest256map_get: Assertion map failed; aborting. (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug: Assertion map failed in digest256map_get at src/common/container.c:1430. Stack trace: (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(log_backtrace+0x42) [0x7f2bfbdefc12] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(tor_assertion_failed_+0xa3) [0x7f2bfbe07b53] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(digest256map_get+0x11b) [0x7f2bfbdf8d8b] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(hs_cache_lookup_as_dir+0x74) [0x7f2bfbde3714] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(+0x192323) [0x7f2bfbdb3323] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(connection_dir_process_inbuf+0x6a2) [0x7f2bfbdb7e42] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(connection_handle_read+0x794) [0x7f2bfbd92af4] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(+0xbc8a1) [0x7f2bfbcdd8a1] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(event_base_loop+0x804) [0x7f2bfbe692b4] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(do_main_loop+0x3f3) [0x7f2bfbcd91e3] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(tor_main+0xe75) [0x7f2bfbcda305] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(main+0x19) [0x7f2bfbcd6319] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /lib64/libc.so.6(__libc_start_main+0xfd) [0x7f2bfadf4d1d] (on Tor 0.3.0.6 47d2e4f06ec26a79)
May 10 12:57:20.000 [err] Bug:     /usr/bin/tor(+0xb5229) [0x7f2bfbcd6229] (on Tor 0.3.0.6 47d2e4f06ec26a79)

Child Tickets

Change History (3)

comment:1 Changed 7 weeks ago by asn

  • Component changed from Core Tor to Core Tor/Tor
  • Keywords tor-hs prop224 added
  • Sponsor set to SponsorR-can

comment:2 Changed 7 weeks ago by arma

  • Description modified (diff)

comment:3 Changed 6 weeks ago by nickm

  • Resolution set to fixed
  • Status changed from new to closed

This was caused by failure to initialize the hidden service descriptor cache. Because the assert was remotely reachable, we worked on the fix offline. The fix is now available in tor 0.3.0.7, and in the branch bug22246_030 in my public repository.

This issue is TROVE-2017-002

Note: See TracTickets for help on using tickets.