Opened 2 years ago

Closed 2 years ago

#22247 closed enhancement (implemented)

Remove deprecation warnings as soon as metrics-lib 1.7.0 is released

Reported by: karsten Owned by: metrics-team
Priority: Medium Milestone: CollecTor 1.2.0
Component: Metrics/CollecTor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are a couple of deprecation warnings when compiling CollecTor, some of which being introduced by preparations for metrics-lib 1.7.0. Once that is released we should remove those warnings by updating to newer code.

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by karsten

My branch task-22247 removes current deprecation warnings, but it should not yet be reviewed and merged, because it requires metrics-lib 1.7.0 at least for the last commit. Putting it here anyway.

comment:2 Changed 2 years ago by karsten

Status: newneeds_review

Please review my branch task-22247-2 which is equivalent to task-22247 except that it contains an upgrade to metrics-lib 1.7.0 before actually using methods that are first contained in that release.

comment:3 Changed 2 years ago by iwakeh

Status: needs_reviewmerge_ready

All deprecation warnings are gone, checks and tests pass.
Ready for merge.

comment:4 Changed 2 years ago by karsten

Resolution: implemented
Status: merge_readyclosed

Thanks for looking! Merged, closing.

Note: See TracTickets for help on using tickets.