Opened 9 years ago

Closed 9 years ago

#2225 closed defect (fixed)

Linux TBB 1.0.17 no longer works on glibc 2.7 distros

Reported by: rransom Owned by: erinn
Priority: Very High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: cgp3cg@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

From http://archives.seul.org/or/talk/Nov-2010/msg00176.html:

Just upgraded from Tor Browser Bundle 1.0.14 to 1.0.17 for Linux i686, running on Debian lenny/5.0.6. Getting glibc errors:

Launching Tor Browser Bundle for Linux in /path/to/tor-browser_en-US
./App/vidalia: /lib/i686/cmov/libc.so.6: version `GLIBC_2.9' not found
(required by /path/to/tor-browser_en-US/Lib/libQtGui.so.4)
./App/vidalia: /lib/i686/cmov/libc.so.6: version `GLIBC_2.10' not found
(required by /path/to/tor-browser_en-US/Lib/libQtNetwork.so.4)
./App/vidalia: /lib/i686/cmov/libc.so.6: version `GLIBC_2.9' not found
(required by /path/to/tor-browser_en-US/Lib/libQtCore.so.4)

Current installed version of glibc is 2.7 (standard Debian version). I guess this reflects a change in the build environment for TBB?

The Linux TBB changelog lists “Rebuild everything against an older glibc so it'll run on more distros” as the only change in Linux TBB 1.0.7, and none of the later changelog entries mention glibc, so I assume this is a bug.

Child Tickets

Change History (1)

comment:1 Changed 9 years ago by erinn

Resolution: fixed
Status: newclosed

I rebuilt the latest Linux TBBs (https://www.torproject.org/dist/torbrowser/linux/) on Debian Lenny (glibc 2.7) so this should be fixed now. Closing, please reopen if you continue to see the problem. Thanks for catching it!

Note: See TracTickets for help on using tickets.