Opened 3 years ago

Closed 3 years ago

#22317 closed defect (duplicate)

downloader fetches index pages (which then fail to parse)

Reported by: cypherpunks Owned by: metrics-team
Priority: Low Milestone:
Component: Metrics/Onionoo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

onionoo version: 4.0-1.2.0

onionoo invoked with: --single-run

folder:
in/recent/relay-descriptors/server-descriptors
contains besides descriptors also "?C=N;O=A" which does not contain descriptors.

Maybe onionoo should not download that (or ignore it)

ERROR o.t.o.u.DescriptorQueue:216 Could not parse /srv/onionoo/in/recent/relay-descriptors/server-descriptors/?C=N;O=A
org.torproject.descriptor.DescriptorParseException: Could not detect descriptor type in descriptor starting with '<!DOCTYPE HTML>
<html lang="en" style="min-height:100%;">
<head>
<title>CollecTor</title>
<meta char'.

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by cypherpunks

turns out this is a duplicate of #20733 which has not been in a onionoo release?

comment:2 Changed 3 years ago by karsten

Resolution: duplicate
Status: newclosed

Not a duplicate of #20733, but a duplicate of #22287 which is from days ago and not yet reviewed. Please move any new findings/aspects to that ticket. Closing.

Note: See TracTickets for help on using tickets.