Opened 2 years ago

Closed 2 years ago

#22440 closed defect (duplicate)

wrap long lines not working in view source mode in TBB

Reported by: gapegas7uftp Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201705, tbb-regression, tbb-6.5-issues
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When chosing CTRL-U / View Page Source in Tor Browser Bundle 6.5.2, and enableing Wrap Long Lines, the long lines do not wrap -- you have to scroll to the right.

Works OK with regular firefox

Child Tickets

Change History (12)

comment:1 Changed 2 years ago by arma

Component: - Select a componentApplications/Tor Browser
Keywords: TBB removed
Owner: set to tbb-team

comment:2 Changed 2 years ago by arma

Toggling the 'syntax highlighting' option also seems to be ignored.

comment:4 in reply to:  3 Changed 2 years ago by gk

Keywords: TorBrowserTeam201705 added
Resolution: fixed
Status: newclosed

Replying to cypherpunks:

https://blog.torproject.org/comment/241854#comment-241854

Good find. The good news is that it is fixed in the latest alpha (7.0a4) and thus in Tor Browser 7.0 which is coming soon. I am not sure which of our changes/upstreamed code in particular solved this, though. And there is syntax highlighting available as well it seems.

comment:5 Changed 2 years ago by cypherpunks

Keywords: tbb-e10s added
Resolution: fixed
Status: closedreopened

This only means your patch is broken in e10s.

comment:6 Changed 2 years ago by gk

Keywords: tbb-e10s removed
Resolution: fixed
Status: reopenedclosed

Please don't add random keywords and reopen tickets randomly. The non-e10s issue is tracked in #22457.

comment:7 Changed 2 years ago by gk

Keywords: tbb-regression tbb-6.5-issues added

comment:8 Changed 2 years ago by cypherpunks

Who are you trying to fool?
https://browserleaks.com/firefox
Please don't do random estimations and close tickets randomly.

comment:9 in reply to:  8 ; Changed 2 years ago by gk

Replying to cypherpunks:

Who are you trying to fool?

Nobody, I just did not look closely enough at the issue.

https://browserleaks.com/firefox

Thanks for pointing that out. I've opened #22459 for the adaptation of our nsIContentPolicy usage.

Last edited 2 years ago by gk (previous) (diff)

comment:10 in reply to:  9 ; Changed 2 years ago by cypherpunks

Replying to gk:

Replying to cypherpunks:

Who are you trying to fool?

Nobody, I just did not look closely enough at the issue.

Then reopen this ticket and close #22457 as a duplicate of it.

https://browserleaks.com/firefox

Thanks for pointing that out. I've opened #22459 for the adaptation of our nsIContentPolicy usage.

You should check all your patches for compatibility with e10s, if you're going to ship it.

comment:11 in reply to:  10 Changed 2 years ago by gk

Resolution: fixed
Status: closedreopened

Replying to cypherpunks:

Replying to gk:

Replying to cypherpunks:

Who are you trying to fool?

Nobody, I just did not look closely enough at the issue.

Then reopen this ticket and close #22457 as a duplicate of it.

Let's keep this as duplicate instead as #22457 has a proposed patch and some further discussion that could be helpful for addressing this problem.

comment:12 Changed 2 years ago by gk

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.