Opened 3 years ago

Closed 4 months ago

#22450 closed defect (wontfix)

Tor works in compatibility mode on Windows 7 and later

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Minor Keywords: tor-client, windows, win32 needs-windows
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are two things:

  1. Tor.exe process runs in "Windows Vista" OS Context.
  2. Tor.exe process runs with Virtualized UAC.

Child Tickets

Change History (7)

comment:1 Changed 3 years ago by teor

Status: newneeds_information
Version: Tor: unspecified

Did you mean "doesn't work"?
Or are you reporting a successful test?

comment:2 Changed 3 years ago by cypherpunks

Status: needs_informationnew

Nice joke, teor. But this ticket is about current behavior. Tor is not compatible with Windows 7 and later, thus OS runs it in compatibility mode and with Virtualized UAC.

comment:3 Changed 3 years ago by dgoulet

Milestone: Tor: unspecified

Missing milestone.

comment:4 Changed 3 years ago by nickm

Keywords: win32 needs-windows added

comment:7 Changed 4 months ago by teor

Resolution: wontfix
Status: newclosed

It's been a few years, and these compatibility modes isn't actually causing us any problems. So I'm going to close as "wontfix".

If there are any bugs caused by these compatibility modes, please open a separate ticket, and reference this ticket.

We don't actually package tor for Windows. (But Tor Browser does, as do other apps.)
Packagers should feel free to distribute tor with a manifest, if they would like to.
Let us know if there are any problems during testing.

Note: See TracTickets for help on using tickets.