Opened 3 years ago

Closed 3 years ago

#22462 closed defect (fixed)

In a debug build of Tor Browser, Page Info causes an assert

Reported by: arthuredelstein Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-7.0-must TorBrowserTeam201706R
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Child Tickets

Change History (8)

comment:1 Changed 3 years ago by mcs

Cc: brade mcs added

comment:2 Changed 3 years ago by arthuredelstein

My progress so far: I have narrowed the problem down to one of our preferences, set in
TB4: Tor Browser's Firefox preference overrides. Working on figuring out which one it is.

comment:3 Changed 3 years ago by arthuredelstein

The pref that causes a crash with Page Info in a debug build turns out to be "browser.privatebrowsing.autostart". And indeed if I turn that pref off, but after Firefox starts, I open a "New Private Window", then Page Info also hits the assert.

comment:4 in reply to:  3 Changed 3 years ago by gk

Replying to arthuredelstein:

The pref that causes a crash with Page Info in a debug build turns out to be "browser.privatebrowsing.autostart". And indeed if I turn that pref off, but after Firefox starts, I open a "New Private Window", then Page Info also hits the assert.

Sounds like a Firefox bug to me worth reporting. Could you file a ticket? We might get some workaround/fix we can still squeeze into 7.0.

comment:5 Changed 3 years ago by cypherpunks

It looks like such assertions are not rare https://bugzilla.mozilla.org/show_bug.cgi?id=1319908

comment:6 Changed 3 years ago by arthuredelstein

Keywords: TorBrowserTeam201706R added; TorBrowserTeam201705 removed
Status: newneeds_review

It turns out this bug was already fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=1329521, but unfortunately ESR52 was not patched. Here is my backport for review:
https://github.com/arthuredelstein/tor-browser/commit/22462

I tried reproducing the "Browser console" issue also reported in that Mozilla bug but was unable to do so, so I am not backporting the other patch from that bug.

comment:7 Changed 3 years ago by mcs

r=mcs
This looks good to me, and it seems to fix the problem.

comment:8 Changed 3 years ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks. Applied to tor-browser-52.1.1esr-7.0-1 and tor-browser-52.1.0esr-7.0-2 (commit a63362cbdd952afdeed64c36ba21b6b94aa5d01b and 3f5f0f7d0b7a3384f5b46d2abef6b1bbf631077e).

Note: See TracTickets for help on using tickets.