Opened 5 months ago

Closed 8 weeks ago

#22471 closed defect (fixed)

Downloading pdf files with the download button in the pdf viewer is stalling

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-7.0-must, tbb-e10s, tbb-7.0-issues, tbb-regression, tbb-7.0-frequent, TorBrowserTeam201708
Cc: mcs, brade, Samdney, teor Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor4

Description

This is one of the remaining issues of #21766: our external helper app dialog blocker leads to a stalled download using the download button on the pdf viewer. Right-clicking and using Save as... is still working, though.

mcs wrote in #21766:

We have not found a fix for the pdfjs download problem, but I think the reason our earlier fix is ineffective is because a blobURI is used for the download, and therefore the channel associated with the download cannot be suspended (suspend and resume are only implemented for some channel types). So in this case the suspend/resume solution won't work.

Child Tickets

Change History (10)

comment:1 Changed 5 months ago by gk

Keywords: tbb-e10s added

comment:2 Changed 5 months ago by gk

Sponsor: Sponsor4

comment:3 Changed 5 months ago by gk

non-e10s mode does not seem to be affected by this.

comment:4 Changed 5 months ago by gk

Keywords: tbb-7.0-issues tbb-regression added

Regression from 6.X.

comment:5 Changed 4 months ago by gk

Keywords: TorBrowserTeam201707 added; TorBrowserTeam201706 removed

Moving Tickets to July 2017.

comment:6 Changed 3 months ago by gk

Keywords: tbb-7.0-frequent added

Tracking frequent 7.0 reports

comment:7 Changed 3 months ago by gk

Keywords: TorBrowserTeam201708 added; TorBrowserTeam201707 removed

Moving our Tickets to August.

comment:8 Changed 3 months ago by gk

Cc: Samdney added

Resolving #23102 as duplicate.

comment:9 Changed 2 months ago by gk

Cc: teor added

Reolved #23299 as duplicate.

comment:10 Changed 8 weeks ago by gk

Resolution: fixed
Status: newclosed

Fixed by the patches in #22618.

Note: See TracTickets for help on using tickets.